Servers by jDrones

Large EKF yaw resets and toilet-bowl effect almost causes crash

Hi, today I ran three flights on my quadplane:

  1. Flew the aircraft with QHOVER and FBWA successfully.
  2. Autonomous mission #1: Got a EKF Yaw Reset -1.00 message and the aircraft yawed about 90 degrees after takeoff. Had to land in QSTABILIZE.
  3. Autonomous mission #2 after recalibrating the compass: Aircraft began to exhibit "toilet bowl " behavior aka yawing clockwise even after switching to QSTABILIZE with 100% throttle, and almost crashed.

The aircraft seemed to work perfectly fine on the first manual flight, but began to show yaw-related problems afterwards during the AUTO flights. An EKF yaw reset of -1.00 is about 60 degrees and that seems quite extreme. In a previous case where a 0.43 EKF yaw reset occurred and I had to take over and land, a compass recalibration solved the problem. I do find that I have to keep re-calibrating the compass, but the calibration procedure succeeds every time on the Default level of offset acceptance on MP. I currently am using a Pixhawk 2.1/Cube with a Here GPS, but the Here GPS compass is disabled for now,

Does anyone face similar problems, or know how to solve this? Any help would be appreciated.

Here are the logs (Flights 1 and 2 are in log 01, Flight 3 is in log 02): https://drive.google.com/open?id=1OJ0bYf8AN1orfB8xQWZf1IWzL5_3z19W

Thank you!

1 Like

In this picture - it actually looks like the toilet-bowl behavior is desired! (Log 02) The desired yaw slightly lags behind the actual yaw, so I’m not sure what to make of that. The CH4 input is quite stable and isn’t requesting for this much yaw after QSTABILIZE so I’m not sure why this is the case.

Also in Log 01 the EKF Yaw reset is clearly indicated (BARO.Alt is green, AHRS.yaw is red)

Hi @frizensami:

Im facing the same exact problem, I know it have been a while from this post but I want to know if you manage to fix it. I have 20 drones ando some of them have this problem.

thanks
LM

Hi @Luis_Montoya @frizensami
i dealing with the same problems with the current fixed wing i working on. I was wondering if you guys found a solution to this problem.

thank you
Jordan

Servers by jDrones