Large change in mag_field, Copter crashes

Hi there !

I’m using Pixhawk 2.4.8, Arducopter V4.1.5, DJI F450 frame, NEO-7m externally mounted compass.

The problem is, despite the primary compass set to external and the external compass being mounted 20cm from the base, i’m getting too large changes in the mag_field value. That was the main reason for the quadcopter crashing many times recently after uncontrolled spins.

Is there any solution to this ?

(Note: I’ve screwed the compass stand to the DJI metal base plate near one of the arms)


Have you tried compassmot? I never could get it to work BTW. Otherwise you would need to try mounted the compass further away from wires etc. I still have the issue on one of my frames so I just take of in stabilized or hover as opposed to loiter and it will usually settle after a few seconds. In another frame I installed a Cube orange and dont have as much of an issue. They seem to have better isolation.

1 Like

What’s reported in Auto Analysis is not really relevant, it’s far from up to date. Post a .bin flight log for analyis.

Where you doing the compass calibration with usb power or with the flight battery?

I had some issues in the past, as my cables of the flight battery were to close to the I2C wires for the external compass. This resulted in not being able to calibrate using the flight battery.
Best regards Maarten

1 Like

If durig calibration the magnetic interference from the battery cables is already too high then there is no way the vehicle will operate safely, let alone be stable.

Sort you cabling issues first, keep active compasses away from the high power wires and it will work fine, like it does for everybody else.

1 Like

Thanks for the kind response.

I did some shielding and repositioning of the external compass.
Compass Motor callibration now shows max 10% interference with 50% throttle. Which is just fine for me.

The issue i actually understand is:
The pixhawk is using internal compass for flight (that is facing the interference) despite the external compass being the only one selected for the flight configuration.

I tried many tests with and without internal and external compass, same results every time. But the MOT_COmpass callibration still shows very minimal interference (as it is truly reading
the external compass during the test).
Also when i try move the external compass, yaw does’nt change but moving pixhawk slightly changes the yaw motion instantly. (when only external compass is selected)

This makes me believe that, pixhawk is using the internal compass during the flight despite the external being the only one selected.

“the toilet bowling happens mostly during throttle changes”

00000047.BIN (665.1 KB)

This is what you have configured:

So you have priority set to the compass that is disabled. You don’t have 2 external compass’s? Strangely both of those device ID’s code for I2C bus which is external. Usually internal compass’s are on SPI. But who knows another 2.4.8 version perhaps.

Other observations. The correct firmware for that Flight Controller is Pixhawk1 not fmuv3. It doesn’t look like you have set any Initial (pre-maiden flight) tuning parameters. There is a screen in Mission Planner under Mandatory Hardware, Initial Parameter Setup.

Hi thanks!

I’m using 1 external compass only (it reads HMC5883). The internal is also on an I2C bus.

The board i use looks like a clone. It comes with an instruction to use only fmu3 to avoid bricking.

I tried initial parameters setup once, the quad became shaky and less stable afterwards. Did a reset on software and parameters to bring it back to stable.

I just observed one more thing, the battery voltage of my new LiPo 3s 5200mah 35C drops from 12.5V to 10.5V all of a sudden after takeoff, the quadopter also faces rise and fall issues due to that in stable flight mode.

The compass yaw is also observed to drift away during the low voltage interval.

What can the issue be?
Is this much voltage drop permissible ?

Voltage Sag occurs when there is high current draw
Magnetic Interference increases with high current

So we can conclude that Magnetic Interference increases with Voltage Sag because both of them are a function of current