Landing gear problem

I’m new to the pixhawk and while I’m waiting for my props to arrive I decided to add electric landing gear. I have set channel 8 to landing gear and am using aux1 and have set RC_9_FUNCTION to 29. I can raise and lower the landing gear using channel 8 on the tx without any problem. PWM is 2000 for down and 990 for up. If I arm the copter and give it half throttle (no props on) and pick the copter up then select LAND on the mode switch then the landing gear RETRACTS the motors stop and the pixhawk disarms! If I do the same but raise the landing gear first then then select LAND then the gear stays retracted and again the motors stop and it disarms. Is this something to do with the way I’m testing or have I done something wrong? I tried setting RC_9_REV to -1 but it still does the same.

Thanks in advance :slight_smile:

After reading a bit further I decided to try reversing the values in LGR_SERVO_RTRACT and LGR_SERVO_DEPLOY. This worked fine but meant I then had to reverse the channel in the Tx to make manual retraction work correctly. Anyway, its all OK now and my apologies for posting before checking properly.