Servers by jDrones

Landing flare in FBWA mode

Hi,

I fly an XUAV Clouds with a pixhawk running ArduPlane. Had loads of problems with flying at the beginning. The drone crashes when flown in Manual/Stabilize. I don’t know why it happens, similar problems have been reported by other users on rcgroups. Oversensitive controls? However, in FBWA it flies great. For safety, I’ve added a generous sink rate when flying with no power and limited the roll rate to avoid dynamic stalls.

All is fine until landing. Staying in FBWA is not a best idea because of the significant sink rate. Switching to manual means troubles. So is there any way to get a landing flare in FBWA? I mean, stop flying downwards to trade altitude for airspeed and try to fly horizontally reducing the airspeed? How about activating such a flare with a RC channel, enabled below certain altitude?

The only automated landing I could find were those in AUTO mode, but I would prefer to land in a (supported) manual mode, without programming the exact location.

Right now, my landings are rather hard:


My temporary solution is to land in the weeds, reducing the impact :slight_smile:

EDIT: I have the following ideas after the potential landing flare mode:

-it would be better to make it a separate flight mode rather than triggered by RC, so that it would be entered from any autonomous flight mode (FBWA, FBWB, LOITER, CRUISE, etc)
-parameters:
–angles of flight (or vertical speed) when the elevator stick is moved to min and max positions. For example, for landing on a slope

normally landing in FBWA is easy as you just pull back gently on the pitch stick when you want to flare. What is it that makes that hard on this plane?
Feel free to post a log if you want me to check things.

You need to understand why you cannot fly your plane in Manual – I am sure you know that and have heard that before. Any video of the flight in Manual? Is your COG correct? Throws need to be dialed down?

Hi,

thanks for both answers. I know that I should be able to fly in Manual - but I’m not . Actually, I have crashed the a/c so many times that it survived only because I have been (cunningly) flying over a very dense layer of weeds and it was me who suffered more while recovering than the Clouds :slight_smile:

I don’t know where the problem is. Have never experienced it with any of my other planes (that’s my first one with the V-tail, by the way). I don’t think it’s the matter of CoG - should this be too much aft, it would enter a flat spin. Instead, it looses the elevator authority and enters a steep nose dive. As I said, some other flyers have been reporting the same. In particular, it happens with no motor thrust. I attach a log where, shortly before landing, I’ve entered the stabilize mode (from FBWA). I also add the screenshot from APM Planner of this critical landing sequence - first I was able to fly level, and then (maybe I’ve pulled too much) it entered the steep dive (over a dense blanket of cane weeds, so nothing bad happened). But notice that the airspeed and AoA have remained stable, so it wasn’t a stall?

I was so frustrated with this airplane that wanted to give up. And then i’ve read on rcg: just fly it in FBWA, including take-off. And it works great. But how about the landings?

But… ArduPlane offers a perfect envelope protection for the most of the flight. Why not to extend it to the most critical phase of landing? Switching to manual is always a bit risky (a potential stall, being out of trim etc). I want Clouds to just ride my gimbals safely… This attitude is typical to the professional aviation nowadays. There are airplanes so unstable that they won’t fly without a computer (fighter jets). And last year a Russian SSJ-100 crashed because it was forced by a lightning hit to the direct mode (FBWA->manual in ArduPlane terms) and the pilots were too panicky to safely land a perfectly flyable aircraft. So even if I would somehow get it right with the manual mode, I would still be very happy with a flare mode - much safer in normal circumstances.

I’ve tried to upload the log file, but it’s too big - so I provided a link:

log file

landing_xuav|690x218

I can see why this plane would be hard to fly in MANUAL! It is quite nose heavy and also tends to turn left.
The first thing you should do is set SERVO_AUTO_TRIM=1. That will make it learn the servo trims while flying in FBWA or AUTO (and other attitude controlled modes), and willl then save those learnt trims for use in MANUAL mode.
You should also move the battery a bit further back. With SERVO_AUTO_TRIM=1 you will be able to tell when you have the CoG right as when you land you can put it in MANUAL and the servos will move to the trimmed position it has learnt in flight.
Next, re-do your RC calibration. It is off by a bit in MANUAL.
Finally check your rudder (V-tail) trim, adjusting the SERVO1_TRIM and SERVO4_TRIM until it is neutral with no stick input.
Cheers, Tridge

Great advices! Thanks so much. I’ll give a try and report. Note how advanced AP is being able to compensate all that.

Could you please tell how you’ve deduced that it’s too nose heavy? Good to know, I would want to check all my other planes.

“With SERVO_AUTO_TRIM=1 you will be able to tell when you have the CoG right as when you land you can put it in MANUAL and the servos will move to the trimmed position it has learnt in flight.” - and what then? How I’ll be able to know if the CoG was right?

How is the landing flare mode working in the auto mode (pulling back the yoke, maintaining the level flight and allowing the AoA to increase until stall?) and would it be hard to enable it for FBWA?

EDIT: one more remark: X-UAV Clouds is relatively short, so it can be expected to have problems with longitudinal control. As I have been taught during gliding lessons, too much CoG forwards shouldn’t be a serious problem until the elevator doesn’t run out of its authority - but this would mean WAY to much CoG forwards? And my Clouds is simply falling out of the sky… Is this not related to a disturbed airflow around the tail stabilizers? I will try it out nevertheless…

You may also try this parameter STAB_PITCH_DOWN, as default it’s 2, change to 1.

I’ve set STAB_PITCH_DOWN to 5, as I want to be on the safe side during the flight. I think that I’ll be happy if the trims will be adjusted automatically when switching to MANUAL, need to give a try. But it would be very nice to have a flare mode without leaving the “assisted” modes. Could canceling STAB_PITCH_DOWN (setting to 0, for example with an RC channel) do the job when staying in FBWA?

Servers by jDrones