Servers by jDrones

Landing Flaps Parameter Questions


(Atico) #10

It is not necessary to have the armed plane to test it
When you recalibrate RC, do you leave the flap sw in neutral position?


(Paul) #11

Ok, I think you are saying to calibrate the radio when the flap channel (7 in my case) is in the middle, or neutral position. I have my flap channel on a 3-position switch to get up flaps (no deflection), half flaps (a little deflection) and full flaps (full deflection).

Both of my flaperon channels servo1 and servo5 are reversed.

With the flap channel 3-position switch in the middle position (1500us), I recalibrated and rebooted. But the flaperons still do not move automatically when I go to AUTO mode with the takeoff flaps set to 33%.

Not sure if I need to have servo7 function set to 3 since there is no seventh servo output, and the flaperon instructions imply that the auto function is already set.

I’m still missing some magic.

Thanks,

Paul


(Atico) #12

you must recalibrate RC with the flap aligned with the trailing edge of the wing


(Paul) #13

Atico,

I tried re-calibrating with the flaps in the “flaps-up” position. Still no good result. I am going to give this a rest for a few days and pick it up again when I am fresh.

At this point I have:

Flaperons configured to go up when deployed, so technically they are spoilerons. They are controlled from the RC transmitter by a 3-position switch to give three settings: None, half, and full spoilers.

FLAP_IN_CHANNEL = 7
SERVO7_FUNCTION = 3

SERVO1_FUNCTION = 24 (flaperon right), inverted
SERVO2_FUNCTION = 25 (flaperon left), inverted

TKOFF_FLAP_PCNT = 33 (for bench testing only because spoilers are not good for takeoff)

LAND_FLAP_PCNT = 25

FLAP_1_PERCNT = 25
FLAP_1_SPEED = 11 m/s

FLAP_2_PERCNT = 50
FLAPS_2_SPEED = 9 m/s

The setup works perfectly with the 3-position switch when in manual mode, however; the spoilerons will not automatically deploy in AUTO mode for either the auto takeoff setting nor the auto landing settings.

Thanks for your help.

Paul


(Paul) #14

Found another possible configuration error in my setup:

I had dual aileron servo mixing set in my transmitter. The ArudPlane flaperon instructions say to remove all aileron mixing and simply have aileron control go on channel 1.

I removed the mix to my second aileron servo and kept the ArduPlane flaperon mixing in place. In manual mode the ailerons and flaperons still work fine, and attitude corrections work correctly in AUTO flight modes.

I tested the flaperons by setting up a FBWB mode switch. When I switched to FBWB and went to a low throttle position the spoilerons indeed moved. I’ll remove the FBWB setup before test flying. My test will involve the airpseed schedules set up for auto-landing.

When the TFR and rains end I may finally be able to test this again…


(Paul) #15

Had two test flights today. The plane landed much closer to the programmed landing spot, however; I could not at the time tell whether the spoilers deployed or not by watching the landings.

I looked later in the logs and think the spoilers did indeed deploy. See channels 1 and 5 (aileron right and left, yellow and red) “open up” a bit when channel 7 (flap channel, white) goes from 1100 to 1300us.

It also looks like channel 2 (green) started adding some down elevator to correct the trim with the spoilers deployed.

Thanks,

Paul


Flaperon auto landing?
(Paul) #16

Here is an example where both the first and second flap positions were activated. Note the two deflection points on aileron outputs 1 and 5 and the associated changed in flap channel 7.


(Nathan E) #17

Congratulations @flyingw, I’m glad you got things working as expected! I would love to see a video of your autolandings!


(Paul) #18

Nathan,

Thanks. I have the features working, but still am trying to get a nice flared landing near to the programmed landing spot. I keep getting long overshoots.

I can get the plane to ditch right on the spot, but I have not yet found the magic in getting a nice slow approach, flare and spot landing.

Very interesting challenge though, and amazing how ArduPlane supports it.

Paul


(Nathan E) #19

The main things I modified were

LAND_FLARE_ALT
TECS_LAND_ARSPD
TECS_LAND_SINK – this one was causing “ballooning” at the flare point – so consider increasing it to bring the plane down quicker.


(Atico) #20

Using the flaps are not always necessary to obtain a slow and smooth
descent. I think it is more important to have a good setup of the
parameters involved in the descent. I leave a link with my configuration in
case it serves to help someone. in the PDFs for download you have the
parameters that I use.

Excuse my inglish

Regards
Atico


(Paul) #21

Interesting Nathan - I am getting ballooning at the flare point. I have been chalking it up to too high a speed, too high a flare alt. I will now take a look at that SINK parameter.

Thanks,

Paul


(Paul) #22

Atico,

I noticed that your final glideslope of 11.4% is much steeper than what I have been using. I have been using around 5-6%. You also have a much larger field that lets you use a luxurious long approach.

For me sometimes the autopilot adds power during the final approach - maybe that’s because it is trying to maintain a 5% slope. I’ll try a steeper final slope as well. Thanks for the pdf of your parameters too.

Your autolanding was beautiful. It looked liked it was in a nice flare for quite awhile on final approach.

Paul


(Paul) #23

Can I simply use the LAND_FLAP_PERCNT parameter instead of the two FLAP_1/2_SPEED and FLAP_1/2_PERCNT schedule items?


(wkf94025) #24

Paul,

I am still in research mode on landing flaps and auto-landing, but what I did on the glide slope was calculate from DF logs the power-off glide slope in still air for my Radian Pro, and it was in that low double digits range, 10%, 11% or thereabouts. Dropping that substantially in my params would likely invoke motor to maintain such a shallow glide, which I would assume complicates everything.

Kelly


(Atico) #25

Yes, you can,

FLAP_1/2_SPEED and FLAP_1/2_PERCNT >>>> Set to 0
LAND_FLAP_PERCNT >>>> set the value you want, for example to start 60%

Regards
Atico


(Paul) #26

Thanks for your comments everyone.

Had two autolandings yesterday evening both with long overshoots of the landing spot.

The plane was flying faster because of the hot and humid air, and it never slowed down enough to deploy full spoilers. Even when I landed it manually I could not slow it down to the FLAP_2_SPEED.

No further testing until next week though as I have yet another TFR that closes my airspace this weekend.

Paul


(Paul) #27

Atico,

When does the LAND_FLAP_PERCNT parameter activate the flaps? At the DO_LAND_START command in the flight plan?

Thanks,

Paul


(Atico) #28

it does it at the beginning of the approach session, from the last WP to the starting point


(Atico) #29

http://www.sop-fpv.com/descargas/file/57-senda-de-planeo-en-autoland

Test whit this parameters and LAND_FLAP_PERCNT=60

What is your model airplane? weight, span