Land Surface Tracking Problem (Terrain) - Agricultural Drone

Hello everyone.
I made a 10lt Agricultural Drone. Everything was fine. But now I’m having problems with terrain surface tracking. It just doesn’t fly at the right altitude. In terrain fluctuations, it does not follow the surface. It goes almost straight. The TF02 Pro Lidar works just fine. But I’m not sure about the CuAV Nora Barometer.
I’m flying at 7m/s in Auto Mode. Log records are below.
Thank you in advance for any advice and suggestions.

Note: The starting height is correct. The altitude before descending 15m in RTL mode is correct. But it goes almost straight between coordinates. It does not fluctuate according to the land surface. Because of this, the flight can become very risky.

Also, I welcome any advice on configuration and settings.

In the light of this information, I think to set the Terrain_Enable parameter to 0. Thus, it will use lidar data for altitude. Is my thinking correct? I hope I don’t do anything wrong.

Setting up a Mission to use Terrain data

  • downward facing LIDAR ensure it is setup as described here
  • If using GCS provided terrain data set the parameter to 1
  • Using a recent version of Mission Planner (or other GCS that supports terrain following) on the Flight Plan screen, set the altitude type to “Terrain”. Once set all mission commands that include an “Alt” fields will be interpreted as altitudes-above-terrain.

I finally solved the problem. The solution is very simple.
1-) We assign the “RangeFinder” flight mode to a lever-button of the controller.
2-) On the Flight Plan screen, we select “Terrain”. (Terrain_Enable = 1 )
3-) We activate “RangeFinder” from the remote.
4-) We take it in Auto mode and start the task.
5-) Lidar sensor data is used for altitude in flight.