LAND_SPEED Stuck at 32767 m/s


I have a problem with my APM 3.2
My parameter “LAND_SPEED” is stuck at 32767m/S… If i change this value to 75m/s in “standard params” and Click on “white params” it show “parameters succeffully saved” and if i disconnect and reconnect the APM, the value of LAND_SPEED come back to 32767m/S !

I can change and save all others params but i can’t change and save this one …
I have already unistall and reinstall mission planner, reset the APM and reinstall the firmware
Thank you for your help

Try to change it in full parameter list

I solved the problem by putting 30cm/s or 100cm/s or 200 cm/s. I don’t know why but when i put an other value than 30,100 or 200 (if i try, 40 or 70 or 130 for example) the value is unsave and stuck at 32767m/S (even in the full parameter list) strange

Pardon me for saying so but that doesn’t really sound “solved”.

I guess that is more of a mission planner problem then a fw3.2 problem, therefore solved… maybe it should’ve been moved to a section about mission planner, because I find advanced parameters to do that… I have to use extended or full list…

Oh, I get it.
But MP should be able to change speed to any reasonable integer. I haven’t used that function yet so I’m glad I saw you post.

Are you using Mission Planner, or APM Planner ? and - did you report this bug ?

I use MP but have not exercised this functionality as yet. So for me, I don’t really have a bug…yet.

Me, I’m too much of a apm noob still to report any bugs… plus, i’m building a new hex now,no time to fiddle with that… :smiley: x4108s