Servers by jDrones

LAND mode - drifts with the wind

I tried to land my copter in light wind. I was in Stabilize (also tried Alt-Hold) and flipped CH8 switch to initialize the Land mode. Instead of holding the position at which I engaged the Land mode, the copter drifted with the wind. It descended nicely automatically, but having also a significant horizontal speed it tipped over on touch down. It did have a good GPS fix.

I did try an RTL mode too. This one worked perfectly. The copter returned above the launch position and while combating the wind (tilted a lot) it descended, touched down without tipping over.

Does anyone know what parameters I should use to make the Land mode hold position while descending and not drift with the wind?

Attached is a log file:
00000310.BIN (584 KB)

I think your vehicle need auto tune , may-be :thinking:

As far as I remember land mode does not keep horizontal position. It only holds a certain descend speed. So the pilot has to steer it to the landing zone.

If it has GPS lock it should keep position as it’s landing. You had an initial EKF error that wasn’t cleared until after you selected Land Mode. Note the timing of the messages indicating use of GPS by EFK. Those come after Land mode was selected also. So I would say the initial GPS position was not established. If you don’t have live telemetry back to a Ground Station or on your Transmitter to see these messages wait longer before taking off.

Ok. Sorry, my bad. And now some random blabla to get 20 characters.

Thank you Dave. I followed your advise and waited much longer, but I also checked if there are any errors on a computer screen. This time the Land mode worked as you said it would for both Stabilized and Alt-Hold. Really appreciate it. I still have a lot to learn.

The vertical bars with descriptions which you are showing in your graph - how did you get them? Did you make them yourself or it’s one of the options in MP?

Glad to hear it Andrew. Those are graphing options in APM Planner 2.

Servers by jDrones