Servers by jDrones

KDE UVC ESC CAN - no comms

I am having trouble with CAN escs (UAS125UVC) - changed settings on KDE with updated firmware to have IDs and have CAN control. Changed pixhawk settings:
CAN_P1_DRIVER =1,
CAN_D1_PROTOCOL = 2

Current setup I only have one ESC connected - just to get telemetry working etc.

ESC connected to CAN2 and another set of lines with a 120 ohm on high/low.

No telem data seen on mission planner. Tried the KDECAN_sniffer as well and don’t see anything…Any ideas what to try/check?

@OXINARF can you help here?

I suspect you’ve already read the wiki but for others attempting to use these ESCs the AP instructions are here and the official KDE instructions are here.

Of course the ESCs are powered with a battery during these tests? I’m pretty sure they are but just trying to rule out some easy explanations.

Any chance you could include a dataflash log?

@rmackay9 Yes I followed both sets of instructions. One thing I wasn’t sure on is in the KDE GUI there is the option to switch from PWM sync to CANBUS for KDECAN control. I did change to CAN BUS not sure if that was right call - guess I can test in both options.

My configuration currently only has one ESC wired in as I wanted to confirm CAN was working before moving to the other five. I can make a datalog once back at testing rig.

The KDE CAN sniffer example also showed nothing. I have a KVASER that I planned to hook-up which might make debugging this a tad easier.

@havi0019 Did you have a chance to get the dataflash log?

2 12-31-1969 7-00-00 PM.bin (409.2 KB)
2 12-31-1969 7-00-00 PM.bin.log.param (13.8 KB)

Here are the ESC settings:

KDE DIRECT DEVICE MANAGER PROGRAM SETTINGS
PLEASE DO NOT MODIFY THIS FILE OR ERRORS MAY OCCUR
DATE: 11/12/2019 14:57:14

STARTUP POWER: DYNAMIC
DRIVE FREQUENCY: DYNAMIC
SYNCHRONOUS RECTIFICATION: ENABLED
S.R. BRAKING ACTIVATION: DYNAMIC
THROTTLE CALIBRATION MODE: DYNAMIC
THROTTLE CALIBRATION RANGE:
VOLTAGE CUTOFF: OFF
VOLTAGE CUTOFF: 3.2 V/CELL
ADVANCED TIMING: PRECISION
MOTOR DIRECTION: FORWARD
ARMING TONES: STANDARD
PROPELLER HOLD: DISABLED
MOTOR EDITION: DEFAULT
ADAPTER: DEFAULT
KDECAN BAUD: 1000K
KDECAN CONTROL: CAN BUS
OVERLOAD PROTECTION: ULTRA-HIGH
ACCELERATION RATE: ULTRA-HIGH
DATA LOG SPEED: 8HZ
STALL PROTECTION: ENABLED
DEFAULT ESC ID: FIXED
KDECAN ESC ID: ID 02

Currently only have one ESC connected - connected to CAN2, other CAN line on ESC has the data lines connected with a 120ohm resistor

Also reiterating that I have tried uploading the KDE sniffer example and that fails too.

I have a KVASER that I plan to connect to confirm that I can see CAN data - just have to go and get it at another office

This is Copter 3.6.11, not 4.0… KDECAN isn’t available in 3.6.x

1 Like

Strange…does the KDE code live on 3.6? I’ve uploaded the KDE sniffer example…wouldn’t that imply I’m on the right branch? I guess I’ll check once back at my computer

There is no KDE code in 3.6 branch.

Sorry - had a couple pixhawks on my desk - connected to wrong one.

Here is CubeBlack on 4.0 with log/params from a quick arm testcanTest.bin (454.3 KB) .
canTest.param (17.7 KB)

Params look good. Can you set ARMING_CHECK and LOG_DISARMED to 1 and send a new log?

Also, if you can look at what is going on the bus, it would be very helpful.

One thing you can try is setting the ESC ID to a higher number, then run the enumeration (Initial Setup -> CAN, then rotate the propeller/motor - it should make a noise, I can’t remember if before or after you rotate). If communication on the bus is working, it should then have the ESC ID changed to 2.

Servers by jDrones