KDE ESC + KDE MOTORS + Pixhawk 2.1 with APM 3.5.3 help needed


I’m new on the community.
We’ve bought several cube and KDE ESC (UAS55) togetether with KDE (4014XF 380Kv and also 4012XF 400Kv) motors and they are mounted on a X8 configuration.

I’ve an issue, I cannot calibrate properly the ESC. Well it sounds a calibration issue.
We did in the past the auto calibration (with a pixhawk 2) and it was working fine.
Now with the cube we’ve followed the recommendation from KDE and followed the instruction manual but we still have a big issue. It looks like more or less randomly the motor are not starting to spin.

does someone as any idea?

Best regards,
Ced B.

I’m using the same hardware. Can you say exactly what settings you’ve tried?

There’s a few ways to get them working properly with Arducopter. There’s one important option in the KDE ESC settings called “Throttle Calibration Range.” For this setting:

  • Do NOT use “Dynamic” mode. This mode is intended for DJI flight controllers, so the PWM range is a bit weird and may cause your motors to not start at low PWM. This is the default setting.
  • You can use “Manual” mode. This will allow you to match the PWM range to your transmitter PWM range, and will work if you also perform the RC calibration in Mission Planner. This mode allows you to do the typical ESC calibration with your transmitter.
  • KDE recommends using the “Range” setting, and this is what I use. You manually define the PWM range that the ESC should expect; KDE recommends 1100-1940. You don’t have to use that range, but whatever range you use should match your MOT_PWM_MIN and MOT_PWM_MAX parameters. Mission Planner may set those parameters automatically when you do your RC calibration, so it’s probably easiest to set the range to be equal to your transmitter’s PWM range.
1 Like

I had the same issue. One esc was DOA, and another worked for the first couple days, then began randomly not arming with the rest of the motors. Finally, it stopped working altogether. Replacing the esc fixed. Altogether, I purchased 6 KDE esc and 2 were defective.


thanks for your reply, I was travelling yesterday and could not answer you. We did what was recommended in the past by KDE the Manual Mode and as it was not working so we’ve tried the Range settings.
The settings is the one indicated in the esc manual, so esc type “oneshot”, PWM min/max at 1100-1940.

the big issue is that it’s not always the same motor/esc which is not spinning… Yesterday we’ve armed 10 times in a row (with disconnecting batteries betwheen each procedure) and all 8 motors were spinning. We then had lunch and after we tried the same configuration and randomly one or two motors were not spinning in the 4 next attemps…

We continue our tests today…


was it always the same ESC which was not arming? or the defect ESC was somehow corrupting the complete system?



We have made further tests, this seem to have nothing to do with the pixhawk… With connected one esc directly to the receiver (futaba) and made the test without autopilot, it has the same effect, some ESC doesn’t start at the first attempt and then they re-armed again (we hear the beeping tones), and then only they can start spinning the motor.

We have upgraded the ESC with the latest firmware that was maybe a mistake… We have some which have not been open, and the first one we’ve open and try is working properly (with an older firmware)…
Does one of you have by luck the A460117 firmware version?

Yes, we have flown on both A460117 and A460120 (latest) firmware. They both worked.

Still possibly like a PWM range issue. When a motor fails to spin on arming, does it start spinning if you throttle up a bit in Stabilize? If so, double check your MOT_PWM_MIN=1100. If that is correct, a workaround is to increase MOT_SPIN_ARM and MOT_SPIN_MIN.

In our experience, all the symptoms you describe were related to mismatched PWM ranges, including the ESC restart (beeping) after trying to arm. See if they start normally when you send a slightly higher PWM.

Just 1 esc. The same esc every time. Even in stabilize approaching liftoff throttle, the motor would not spin. Switched to a spare and it’s been flying flawless for 20+ flights now.

hey Ced, I’ve found mine are behaving much better with oneshot and not oneshot125. What signal are you using? With oneshot125, some or all (was random) motors refused to spin after a disarm and rearm without power cycling. Now I can cycle arming without issues.

Good morning Rick and Keith,

We’ve downgraded our ESCs to the FW A460117 and now all motor are spinning.

The point is that we had a setup without the pixhawk connected, so it should not depend on the oneshot or oneshot125 selection in PH 2.1, or any MOT_PWM setting.

Actually what’s weird is that we can really notice a little difference in the behaviour of the ESC, the ones who had the issue have a kind of jitter, we can still sometimes hear it but now they start. We’ve one of them not installed so we’ll propose KDE to send it back for investigation.

Now our setting is as recommended by KDE, so ESC type set to oneshot, Range mode and 1100-1940 PWM range set in PH.
Nevertheless, in the previous setup we were using ESC type default, manual mode and ESC calibrated and it was also working.

I’ll let you know once we get an answer.

Hi, I am having the very same issue. X8 KDE 55 ESC’s. Set the ESC’s to Range mode, with a min at 1100 and a max at 1940. Mission Planner is set the same with Single Shot. Motors are not starting together and/or not spinning at the same speed. After several stops and starts, several motors would not arm at all. Unplug the batteries and plug them in, they all start, not taking off, just stopping the motors and starting again, and random motors would not start. As suggested above, I checked the MOT-PWM settings and they agree with the type consistent. I find it hard to believe that the ESC’s are bad as the craft was flying fine with an A3 controller. On the KDE web site it says at the bottom of their instruction PDF to set the ESC control frequencies at 400Hz Dynamic? Would this be the ESC’s Drive Frequency? I have no idea where to set the Control Frequency.

The irony is I have switched to T-Motor’s Navigator series for the motors and still using KDE ESCs, and the ESCs are working flawlessly with T-Motor. So part of the problem is KDE’s curved magnet layout and their ESCs unable to always tell the motor direction at startup.

KDE definitely has issues on their software side.

I found a bug in one of their ESC firmwares 2 months ago and they confirmed the bug and said it will get fixed. It’s still not fixed today. The bug is Drive Frequency “Precision” refuses to apply to their 20A esc. So I’m stuck using a less efficient setting.

ESC settings don’t make sense either. For instance, ESC tone setting “Arm Only” sounds like it should only make a tone at arming. Instead, this setting also makes constant beeps while disarmed. “Initialize” is the setting that makes a tone only at arming. Seriously??

Their Drive Frequency options are Precision, Dynamic, Balanced. Only Precision makes sense as that’s the fastest frequency option, but Dynamic is simply a slower frequency, and Balanced is the slowest. Makes no sense whatsoever.

Earl, my DOA esc had this symptom. It refused to work in Throttle Calibration Mode “Dynamic” (there goes that damn dynamic moniker again). But it did spin in “Range” setting, but at less than half the speed of the other 5 motors which were also in Range. It spun at 33% of the other motors. Only swapping the ESC fixed.

Thanks for your comments. This is where I am. In looking at the KDE Device Link Menu included in KDE’s PDF on configuring their ESC’s to the Pixhawk I noticed several anomalies to my settings and theirs and also between ESC’s. Don’t know how that happened, but I went through and set all the ESC’s to default and then applied the Range settings. That made them perform better but I still had an issue of a couple of motors not starting on the 3rd continuous start/stop and start again. Also, could not take off correctly in Stability Mode.

Our vacation home, where I work on these, is on the outer limits of a small airport, I believe Class E, which DJI has listed as my area as a NFZ so they shut down my A3 when flying out of here. Today, I am going to reinstall the A3 and drive aa little north and test the KDE motors and ESC’s. Maybe that will not help with the Pixhawk.

Having failed at getting the KDE craft to work, I have an old X8 with T-Motors and an older T-Motor ESC. After some work at performing the calibration of the ESC’s I could get all of the motors to start and appear to work fine. Then I went through the process of putting on the blades to get ready to do the Motor Test again and I could not make them work at all. When I would push “A” they all wanted to spin. (this is under “Normal” ESC calibration. Am getting REALLY frustrated with this process and it should not be this difficult.

On Ardupilot’s web site it gives the motor order for a X8 (front right and going around to the left as 1, 2, 3, 4 (5 starts under 2 and not 1)and then rotates in the opposite direction with 6, 7 and 8. Now the same page says the motor test will spin motors in this sequence " it will spin the top front-right motor first, then the bottom front-right, and proceed around with the same pattern" .(I will include the link) So I take this sequence to be the ones in black.([http://ardupilot.org/copter/docs/connect-escs-and-motors.html](http://X8 Order) The red ones are what I experience.

Last Question: Does the Pixhawk cube 2.1 need power added to its ESC rail for the KDE motors (Optoisolated ESCs) KDE says no but in reading the Ardupilot documentation it is unclear?

Yes you need to supply voltage to the esc rail. Pixhawk does not provide power to ESCs. I am using a Spektreworks carrier board for my pixhawk which has dual 5v power supplies. So all I had to do was apply a jumper to send 5v to the ESC rail. Otherwise, I suggest using KDE’s UBEC and apply it to your ESC power rail. I’m not sure where you read KDE says no since they provide their own UBEC to power their ESCs.

I was going to suggest re-checking esc options because I also had settings not save several times.

I think the test order of motors on X8 frame is best understood when you think of the bottom motors being a flipped quad.

Thanks again for your comments Keith. Yes, yesterday I went into the KDE’s Device Link and I discovered that APM had changed several of he settings in the ESC’s. I now have a separate issue with the KDE ESC’s/Motors I have been working on and going to have to replace them. Now my only goal is to get the T-Motors working.