Kakute H7 v2 Log Writing and Autotune Issue

This FC uses onboard dataflash memory instead of a SD card and it seems that I may be running out of memory which prevents completing Autotune and writing the complete log?
When running Autotune on two occasions, one in pitch and roll and the other in roll, the autotune seems to complete on both occasions but instead of the usual beep and LED signal the quad just sits there. After landing with autotune still enabled and then disarming the PIDs are not written.
Attached is the .bin file of the autotune in the roll channel and it just stops midflight.
If anyone can provide some guidance on this issue or parameter settings (LOG_FILE_BUFSIZE or LOG_FILE_MB_FREE??) that would help, it would be appreciated.


The other issue downloading the log and I get this error .

It appears that when the log is downloaded it initially stores it on my machine with a name of ‘1 1-01-1970 1-00-00 pm.bin’. When the download is complete It then converts the file to one with another date.
If for some reason, there is already a file called ‘1 1-01-1970 1-00-00 pm.bin’ in the download folder, it won’t overwrite the file and gives an error and the log is not downloaded. This only my guess what is happening, but I know I have to delete the ‘1 1-01-1970 1-00-00 pm.bin’ to get the download to work. Anyone know how this works?

Doesn’t look like it completed

But why did the log stop writing?

I think you are right - you ran out of space. 128Mb max

1 Like

last night pitch tune same issue but gains saved
3inch frame
fc skystar H743 hd

1 Like

Thanks for the replies and it seems this FC is not ideally suited for ArduCopter. I have Kakute H7 V1 which I might try instead, unless others have issues with this or there are other better suggestions?

Matek H743 boards.
I have other Kakute boards that perform fine but that one seems to be a dog.

1 Like

The Matek H743-Wing-V3 looks the pick of the bunch but not sure about a matching 4 in 1 ESC??

It will match any 4-in-1 you will just need to connect the wires correctly, which is pretty trivial

1 Like

I flew this board fine. Obviously you have to be a little bit careful with the logging, but its manageable. A lot of the newer H743 boards have this logging setup.

1 Like

The reason you ran out of log space is you have FAST ATTITUDE logging enabled - this will fill up the log really quickly. Try with 4112382 in LOG_BITMASK - should work a lot better. Not really worth setting FAST ATTITUDE until you are ready to do a test flight.

1 Like

@Peterarnold I have seen that if you have a working gps and activate the geofence the log files are downloaded with the correct date and the correct name. Here you see a full log message (chip full) after flying 18 minutes with my 3" coper 2s li ion powered

1 Like

I tried the LOG_BITMASK setting with Autotune which ran for about 3 minutes then stopped. Nothing written in the log so I thinks it is a faulty FC. A dog destined for the thrash can!
Thanks for all the help with this!

Note that the flash log can get corrupted. If you think this is the case do “clear all logs” in mission planner - this will wipe it and often solves logging problems with this driver. Longer term I have a plan to support littlefs which should be more reliable than the current scheme.

1 Like

The bit I don’t understand is why the autotune stopped. If logging failed or became corrupted would that stop the autotune? Both issues seem to occur together.

Yeah, I am not sure. Generally if logging has failed this will show up as an error on boot and you won’t be able to arm. It does sound a bit strange - and you may be right, maybe the flight controller has a defect - just pointing out that flash-based logging is a little flaky, but as long as you realize this its fairly straightforward to work around. Are you using log rotation? You should with this board.

Please explain Log Rotation?

LOG_FILE_DSRMROT,1 will create a new log file every time you arm.

Thanks, I was using that.