Kakute F7: Bootloader Not Recognized in Windows

I have two Kakute F7 Flight Contorllers, and have connected both of them to 4 different windows 10 computers, all with the same result:

  1. They connect perfectly to BetaFlight, and give live orientation data, etc.

  2. Whenever I put them into bootloader mode, either via button push, or BL command in BetaFlight, windows comes back with " USB DEVICE NOT RECOGNIZED ".

I have installed all the drivers recommended by BetaFlight, and Tried Impulse RC Driver fixer, with the exact same results, whenever the device is placed in bootloader mode I get the windows message " USB DEVICE NOT RECOGNIZED ". Keep in mind, that no program setting, etc is going to matter when When windows will not even communicate with the device…

Has anyone seen this or have any ideas ???



I read in several places that disconnecting the receiver from the flight controller solved this for some people. In my case it did not, BUT

Disconnecting the GPS did fix it !!! Impulse RC driver utility worked instantly and I had new firmware on my flight controller within 5 minutes. I connected the GPS back to the Kakute F7, and same problem, bootloader mode stopped working, but I can live with this. I will just disconnect the GPS whenever I need to update firmware, easy enough. Configuration works great all the time, just firmware updates affected by GPS connected to UART # 3.


1 Like