Kakute F7 1.5 - Barometer problem - Unable to initialise driver

Hi Everyone

I used Kakute F7 with previous builds without any problems. By using Betaflight I use to flash the arducopter_with_bl.hex file and it worked great.
Recently I bought the new Kakute F7 V1.5 and I encountered a problem after flashing it. Basically, when I connect with QGC or APM, the following error message appears, over and over:

Config error: Baro: unable to initialise driver

I read somewhere that could be a problem of power supply. I tried everything, mainly power it up first with battery, and then connect it via USB to the laptop. The result is the same

Also, tried to flash many different versions of firmware: 4.0.2, 4.0.3, stable, beta, and latest. Results are always the same

Any hint? Is it maybe the BARO broken or is it a matter of parameters?

Thanks a lot

Any experience on that? Or is it simply a brand new kakute f7 broken?
Thanks, Mike

Try flashing the PX4 flight stack from QGC (or iNav) and see if it errors. If it does it’s a hardware problem most likely.

1 Like

I have that same board and do not have that issue. Might be hardware as Dave says

1 Like

I run a few of those boards.First I power it up and wait tor it to initialize before I plug in the USB.If I don’t do this I get the driver unable to initialize.

1 Like

That’s probably worthy of a note somewhere on our Wiki (@hwurzburg -

1 Like

Thanks for your suggestion! Will try with the PX4 flight stack then … but after your messages, I’m not so confident anymore.
Regarding waiting for a little before connecting the USB, it’s something that I did already. I scraped the forum before posting here and that was the only suggestion I found. I waited up to 60 seconds but nothing changed …

@petebarker doesnt seem like a reliable solution has been found yet, do we have manufacturer contacts?

Hi, Did this issue get resolved?
I’m experiencing it on…
Latest 'Copter, can’t remember version but downloaded just a week ago
It set-up nicely, had a few short flights, but now won’t connect MP due to this message
Used various USB cables, (proved good before)
Used various power-up sequences.
Rebooted laptop, WIN10 BTW

FC is Holybro Kakute F7 AIO v1.5
No sensors powered from the USB, so no GPS, Compass, RC Rx powered when on USB only.
(wondered about this as the external compass is on same i2c bus as the onboard BARO, but still same when LiPo powered)

Tonight I’ll try connecting a SiK telemetry radio and try booting through that.
But at the moment I just can’t connect, so can’t set tuning parameters :frowning:

All help very gratefully received



I have that same problem. If I power from USB, it says barometer failed to work. If I plug in the battery first and start it up, the problem goes away. Before ArduCopter 4.0.7, the problem was not fixed in this way either. In Pixhawk4 mini, the barometer error is not corrected in any way. Fixed Solution: Stay away from HollyBro.

I have a couple Holybro F7’s (AIO and Mini) and no problem with them. The V2 Mini is a great FC.

1 Like

Kakute F7 AIO is really nice card. Already my HollyBro adventure started with this card. Then I bought the Pixhawk Mini. The barometer did not work. Pixhawk 4. Not satisfied at all. I bought 2 Hollybro 500mw Telmetry Modules. Both turned out to be faulty. I almost quit even ArduPilot. When I bought the Pixhawk Cube. That’s when I learned what quality hardware is. Then CuAV Autopilots warmed me back to ArduCopter software. Good thing I didn’t switch to DJI systems.

I don’t have a CUAV Flight Controller but I helped out with a big X8 that had a Nora. I was very impressed with that FC.

1 Like