Servers by jDrones

Jumps in pose when using Marvelmind beacons

(Ajith Kumar) #1

Hi team,

I am currently working on Marvelmind beacons.
I am facing some strange issue that the pose given by the ardupilot after EKF3 fusion is inconsistent. The pose jumps from one place to another consistently. Also, I could observe there is a pattern in the jumps. These jumps extend up to +/- 2m even when the vehicle(pixhawk2 based rover) is in the stationary state.
The position values given by the Marvelmind beacons are correct. I visually confirmed it in the Marvelmind dashboard.
I suspect there should be a problem somewhere in the EKF3.

Has anyone successfully got the Marvelmind beacons work properly with ardupilot?

Please help me to resolve this issue.

Thanks,
Ajith Kumar

(Ajith Kumar) #2

Hi @karthikdesai and @rmackay9,

I think I am facing a similar issue like this Marvelmind no longer working with ArduRover?

@karthikdesai , Has this jump issue been solved?

I know some people actually tried emulating Marvelmind beacons as GPS as MM supports NMEA protocol. I think the EKF measurement update steps will not effectively model the beacons.

Thanks,
Ajith Kumar

(Ajith Kumar) #3

Hi all,

Has anyone successfully achieved Ardupilot non-GPS navigation with Marvelmind beacons?

Thanks,
Ajith Kumar