Servers by jDrones

Joystick mount control broken

(Corrado Steri) #1

When trying to use joysyick buttons mapped to mount control nothing happens, function has been broken for years now. It works on the drop down menu but not from joystick. I remember i fixed it in a mp from a year ago and i’ll fix it in the current master for our use.

(James Pattison) #2

Can you open an issue or PR in GitHub?

(Corrado Steri) #3

I already did it a couple of years ago and asked for a PR with the fixes on the buttons, it has never been taken in any consideration so i think i will not do it again. If anyone has the same prob and wants to fix it i’ll be more than happy to help.
It took me 5 minutes to fix the issue so i guess @Michael_Oborne can fix it. Probably not many people use it so it is not noticed too much.

(Michael Oborne) #4

i will accept any fix you have. so long as you dont break the old implementation. ie make it backwards compatible.

(Corrado Steri) #5

Hello Michael, i don’t think it’ll be backward compatible because i see you changed a lot of stuff since the last time i worked on the joystick (an year ago). Actually i think something changed in the joystick in the last month oir so because my plugin doesn’t work anymore and generate a joystick error. Since i decided not to use the plugin route anymore and change directly the code in MP, once i fix the buttons again i’ll send you the new code and you decide if you want to use it or not.
Anyway, thank you again to have put me in te right direction for the gacutil, without your help it would probably have taken 1 year to fix it by myself :slight_smile: