Joystick in APM Planner

Hi there!

I’m trying to control a APM copter using a PS3 joystick.
I have succesfully connected the joystick to APM Planner using File->Joystick tab. And I have configured the stick properly, assiging its channels and inverting some of them.

Once set properly the SYSGCS parameter an being able to override RCout, I have connected to the GCS APM Copter, I have tried to calibrate the Joystick, using RC Calibration menu.

There I have seeing that:

  • Throttle only has 1080-1500 values ( a bit few)

  • Yaw PWM range is going only one side: center value is 1500 and when I move the stick to the left the value changes until ~1138. But when i move the stick to the right PWM value does not change (fix to 1500).

  • Finally I cannot see Roll and Pitch changing in this menu, even though I can see X and Y axis values changing in the Joystick Menu (under File->Joystick)

I’m using v2.0.15 because 2.0.18 is crashing when I try to connect the Joystick.
Any one has achieved to control the drone with a PS3 under APM Planner

Nore: I have a Mac

Thanks in advance

I have flown using a PS3 joystick in th epast on OSX. try using a daily build or newer beta

I have done it using v2.0.19-rc4 and crashes when opening Joystick tab!
So, any configuration advice??

And this version … 34_osx.dmg

Sent from my iPad using Tapatalk

Also crashes,
Thanks for your fast reply,


I have installed in a native Ubuntu 14.04 APM planner v2.0.19-rc4 and same happens. The only channels where I can see properly the PWM values is in the throttle. Pitch and Roll PWMs are not changing and Yaw just a half.

Now also I’m seeing properly Joystick values at File->Joystick menu.

So how is possible that APM Planner is reading nicely joystick values but not able to write this values to RCoverride?? Any help?

Thanks in advance,


I have made a video showing what’s happening:



Sorry, I haven’t been able to test until now and it seems OSX is broken.

As for the ubuntu video, have your tried reassigning the channels on the right to match? that should fix the problem

Hey @billbonney,

Now I’m seeing poperly the channels. I have fixed channels and parameters related to each RC channel values.

I think that when I tried to calibrate the RC, ~1500 PWM values were set as min and max to RC1&2, so I could not see any value further.

Now I’m struggling in order to get reasonable RCouts. I am using a quadcopter, and not all the motors are spinning at the same speed.
There is any way to calibrate ESCs using Joystick values? I think the autopilot is taking old RC values to make calculations or something like that… Not sure what’s going on

(I’m working under Ubuntu, MacOS is crashing.)


Other ideas to consider about calibration. I had calibration PWM range issues using a Saitek X45 joystick system until I first calibrated in Windows devices and printers. Perhaps this is your issue? Here is what I did before trying to use it in APM or Mission Planner: In Windows/Control Panel/Devices and Printers/Saitek X45 (right mouse click) /Game Controller Settings/Properties, I calibrated the controller before trying to auto-detect and set Min and Max and Trim values for each channel rcoverridech1 to rcoverridech8 in Mission Planner parameters. If the Saitek X45 is not first calibrated in Windows, it will send values that are too small to auto-detect or a range of values that are useable but not ideal in MP joystick operations.