Joystick in APM Planner

Hi there!

I’m trying to control a APM copter using a PS3 joystick.
I have succesfully connected the joystick to APM Planner using File->Joystick tab. And I have configured the stick properly, assiging its channels and inverting some of them.

Once set properly the SYSGCS parameter an being able to override RCout, I have connected to the GCS APM Copter, I have tried to calibrate the Joystick, using RC Calibration menu.

There I have seeing that:

  • Throttle only has 1080-1500 values ( a bit few)

  • Yaw PWM range is going only one side: center value is 1500 and when I move the stick to the left the value changes until ~1138. But when i move the stick to the right PWM value does not change (fix to 1500).

  • Finally I cannot see Roll and Pitch changing in this menu, even though I can see X and Y axis values changing in the Joystick Menu (under File->Joystick)

I’m using v2.0.15 because 2.0.18 is crashing when I try to connect the Joystick.
Any one has achieved to control the drone with a PS3 under APM Planner

Nore: I have a Mac

Thanks in advance

I have downloaded the 2.0.19, and crashes when I open file->Joystick Tab, under MacOS

I have tried to make the same in Mission Planner.
The result is the same, I have just two channels working out of 4.

I have calibrated the PS4 joystick, and the values of rcoverride of ch1-2 are just ~1500, the do not move.
I have tried also one chinesse replica with the same result.

So it looks like joystick problem? Anyone has used a PS3 joystick??