Joystick control - sticks not working

I’m trying to get my little 1/16 car setup to run on a gamepad.

It’s all setup fine with latest beta FW and beta MP, and works with RC.

When I enable the joysick, the sliders move on the joystick page, but nothing happens to the rc outputs.

I can successfully use buttons on the joystick to change modes, and even set channel 8 PWM to 1100 or 1900 with different buttons. However NOTHING works on the channels covered by my receiver - 1-7.

Ideas?

@mroberts,
You might try looking at the RCMAP parameters in the Full Parameter List as they may be different for a gamepad compared to R/C receiver inputs.
Regards,
TCIII Autonomous Vehicle Developer

One correction - I’m using the latest release version of MP, not the Beta.

@TC, I have all four axes mapped (throttle, elevator, aileron and rudder), so I would have though I should see some movement somewhere, even if my mapping is off.

It also doesn’t respond to a button-based DO_SET_SERVO for CH5, but does for CH8

Also, I’m running a satellite receiver, rather than PPM encoder and have turned off throttle failsafe.

An idea: Just check that you have the upper and lower limits for PWM set for each axis, (the same as “radio calibration” if using a RC Tx), you have to set the PWM values manually as there’s no calibration for a joystick.

I reset the calibration to 1000-1500-2000.

RCOVERRIDECH is moving with the joystick, but still no joy on the RC output. It is even locking all the output channels on RCOut to 0 in Manual mode, but 1500 in HOLD.

EDIT: It works for Plane - I uploaded the plane firmware, and the joystick works fine

Complete parameter reset and it now works!!!

Maybe I’ll try running the “compare” and see if I can work out what did it.

Hi,

Just wondering if you ever got this working? It sounds like I am having the same problem. I posted here

http://ardupilot.com/forum/viewtopic.php?f=111&t=13642

everything works for me except the ROLL, PITCH, THROTTLE, YAW, and CH7, CH8. In the Joystick setup page its the controls on the top that dont work the buttons that are configured on the bottom work, I can set them and they change modes, arm and disarm the copter.

thanks

Hi, Dont know if you ever solved this but check the parameter SYSID_MYGCS It needs to be 255 for MP

http://ardupilot.com/forum/viewtopic.php?f=111&t=13642

John