Jetson Nano - Pixhawk Cube Communication

Hello everyone,
I’m a university student. We are working on autonomous drone development project. I’m currently having Jetson Nano board with Pixhawk Cube flight controller. Our idea is to use Jetson Nano as companion computer. But we are lacking the knowledge on how to do it. I’m new to this area. Are there any tutorials or anyone can tell me the steps to follow so that i can establish connection in between Jetson Nano and Pixhawk and read the variable parameters of Pixhawk from Jetson Nano. I really want your help.

@ppoirier Sir, can you help me

Hello,

Wiki is your friend
https://ardupilot.org/dev/docs/companion-computers.html

And jut search on this forum for Nvidia NANO.
Basically, it is MUCH easier to interface with a USB FTDI adapter connected to the CUBE serial

I have to agree with the second statement from @ppoirier . After spending hours trying to get a reliable connection from Nano’s serial port to the Cube’s serial port, I have given up (and so have the 5-6 different people I have worked with who were trying to do similar things). Although I have heard people have been able to get a reliable connection going, but sadly that was not the case with me. The best is to use the cube’s carrier board USB and connect it to the Jetson nano’s USB port, or use a FTDI adapter

2 Likes

Thank you very much sir

Can you tell me how you connected with usb, I couldn’t connect with jetson nano from pixhawk telem2 part and I’ve been dealing with it for 10 days. I went crazy because of this problem :)) I’m using Pixhawk orange cube and jetson nano. If you are making changes to the parameters after installing the latest version in Mission Planner, can you specify them? What baud value do you enter when you connect via usb? What is your connection_string? tyUSBO? Can you specify them please

Hello, I figured it out and got the Pixhawk controller connected with Jetson Nano. Thank you very much for your comments and advices.

I followed Mr. PPoirier suggested and it worked well. You have to get an USB FTDI connector which make reliable connection in between jetson nano and Pixhawk controller. Then you have to specify port with baud rate (my case ttyUSB0, 921600) in your python script as well as you have to set the baud rate and protocol inside the mission planner too under parameters. (for telem 2 - Serial_2 port, protocol - 2 (mavlink)). Then you can easily get connected.

CRITICAL: autopilot: PreArm: Throttle below Failsafe

CRITICAL:autopilot: PreArm: Compass 2 not Found
CRITICAL:autopilot: PreArm: Compass 2 not Found
please help

Hello,

Theses messages are related to Flight Controller configuration, or lack of it… This is not related to Companion Computer.
Please do your calibration and ask question on a different thread if you require assistance on this.

Can you access me from Discord please? I’m on the same project and might help each other. Supervisor⚡#6101