Jetdrive boat not going straight in auto mode

Hello, I have a quite large boat (2 meters long) with a pixhawk 4 mini. It’s powered by a jetdrive.

I’m usint ardurover in mission planner
GPS, accel, compass, works great.

But I have several problems in auto mode :
First The boat is not going straight to the next waypoint but he’s weaving. No matter what PID setup I try, always the same amplitude of weaving…
I think it’s because the throttle is reduced when the pixhawk want to correct the trajectory (I can hear it), but a jetdrive have less autority when the throttle is reduced so it might be the problem. Is it possible to impose a fixed value to the throttle in auto mode?

I tried to set a higher speed for auto mode, but this is the second problem : If I ask for 1 m/s it’s ok, but if I ask for 2 or more m/s, the boat never exceed 1.3 m/s, while in manual mode I can go to 7 m/s!

Thank you for your help

Hi @jeanbat,

Any chance you could provide an onboard log? It is much easier to provide good advice if we have log which shows how the speed and turn rate controllers are doing.

I wanted to, but can you tell me how to do it ?
Thank you


Sure, in my reply above the words, “onboard log” include a link to the instructions on how to download logs.

Ok I faced difficulties to download logs (maybe because I’m on linux) but I managed to get this log file from the sd card : ( the uploading option didn’t work so it’s a link from mega)

Thank you for your help
Fun fact : we can see a crash to the riverbank at the end because of a problem with the ubec who supplies the servo.

Hi, does anyone have an idea for what parameter I should modify ?
Speed is the most important.


Txs for the log.

The steering control looks OK but the navigation controller appears to be trying too hard to keep the vehicle on the line. The navigation controller gain can be reduced by increasing NAVL1_PERIOD from 10 to perhaps 16 or even higher.

Now. at the risk of breaking a working steering controller, if this is a jetboat it should probably be using vectored thrust which can be enabled by setting MOT_VEC_ANGLEMAX to the appropriate maximum deflection angle of the steering. Changing this will affect the tuning so some of the advice below may become incorrect.

Re the speed controller I think the CRUISE_SPEED and CRUISE_THROTTLE values could be improved a bit:

  • increase CRUISE_SPEED to 6 (m/s)
  • increase CRUISE_THROTTLE to 100

Also it might help to reduce the speed controller’s P gain to reduce unnecessary oscillation:

  • decrease ATC_SPEED_P from 0.8 to maybe 0.4 or even 0.2
1 Like