Issues with SmartAudio on Rush Tank Ultimate Plus and Matek H743 Wing V2

I have 4.1.7 running on a Matek H743 Wing V2. The VTX is a Rush Tank Ultimate Plus, and the SmartAudio wire on the VTX is connected to TX3, which apparently corresponds to SERIAL4.

The first issue I’m having is that if I change VTX_POWER via Mission Planner and then write it out, it only registers a change to VTX power in my FPV goggles if I restart the flight controller. I have VTX_ENABLE set to 1, VTX_OPTIONS set to 16, and I’m changing VTX_POWER between 25mW and 800mW, but it doesn’t take effect right away. This seems like a bug, at least I didn’t see it documented anywhere and since we’re supposed to be able to change VTX_POWER dynamically based on an RC channel it seems like it should work via MAVLink as well.

The second thing is that in my FPV goggles the VTX power entry is flashing even if I pick a value that is supported by this VTX, such as 25mW or 200mW.

Thirdly, the SmartAudio connection doesn’t work. It’s unable to modify the setting of the VTX. I have the following:
SERIAL4_OPTIONS=68 (also tried with 4)

Is there any way to get a detailed debug log of the SmartAudio connection attempts?

Lastly, I notice that Arduplane doesn’t seem to support “Band F” on the VTX. Any particular reason for this? I don’t think I’d actually need it, just curious why it was omitted.

Most of these are known problems but I have been stalled trying to work on them because of issues with the TBS firmware. I finally have new, potentially working, firmware from TBS so hope to get to these in due course.

Would I have the same problems with a new TBS VTX? I had hoped that since Rush was TBS authorized it would have a reasonable implementation.

It’s the new TBS firmware that is problematic

Did you get anywhere with this?

I am in the process of wiring this exact setup now and not sure if I should bother with the SmartAudio connection.

I have one on order that I am going to test

Would you like me to let you know what I find when I connect mine in the next day or two?

I reported on mine in another thread but didn’t update this one. (See Help debugging setting VTX Power via SmartAudio? Debug logs included - #6 by cbf123)

I ended up using an Arduino Nano as an oscilloscope and discovered that this VTX is using a single stop bit instead of the two that the spec calls for. (Incidentally, I checked with TBS and they said that Rush had only ever sent in the Tank Solo for testing, which might explain why this one doesn’t match the official SmartAudio spec.)

I’m not home so I can’t check my settings, but I believe I had to use the “RX pull up” setting since otherwise the VTX would send very low-voltage signals in response. (And it has to be set when the VTX is powered on, you can’t change that setting on the fly.)

With those changes I was at least able to switch between pit mode and normal power, but as I recall it was still slightly flaky when changing power levels. (Haven’t been able to work on the model for the last month or so.)

FWIW this is the “iNav” bug. iNav originally implemented SA this way and a bunch of manufacturers copied unthinkingly. I plan to add an option to allow the stop bits to be set.

Just to confirm, I wires up the smart audio pin and configured according to the documentation and can confirm, this does not seem to be working.

Was there any changes with the high power VTX support via Smart Audio?
I have Rush Solo Max 2.5W but it is limited to 1000mW

There is a fix in 4.5.5 for this hopefully

1 Like