Issues with PowerSensor showing incorrect voltage/stuck at voltage


I have an issue with my pixhawk voltage sensor that, while uncalibrated shows 51,80 volts on a 3s battery, no matter what voltage the battery is on.

I tried to calibrate it but it only gets stuck on the voltage I calibrated to i.e. 12.59 volts.

I’ve tried to replace the voltage sensor but I still got the same issue.

Is there something I’ve missed?

Check your sensor output with a multimeter. Sensor out voltage must be less than 3.3V and you must see that with different battery there is a different sensor output.
Also in mission planner you must select proper board type (Pixhawk / Pixracer / etc).

Which pins shoud give me 3v?

I can measure 5v from all pins except from one, who only is at 0.1

Edit: So according to the pinout, the volt pin (PIN4) gives me 5.2 volts.
And PIN3 (amp pin) gives me 0.1.

It’s the same issue with both power modules I’ve tried.

It is always 5.2 volts or it depends on battery level?
Anyway this isn’t looks correct because maximum voltage must not exeeds 3.3V (or that module is not for pixhawk).

It shows over 5,2 volts no matter the voltage.

In fact both of them does, and they were sold as pixhawk power modules, the first one even came with the kit.

I’ve seen similar issues and unless the battery monitor is defective, the root cause has always been a miss wired 6 position cable.

When a “good” cable is laid out flat, one end will have the connector pin locking tabs facing UP and the other end will have the “blank” side of the connecter facing up…!ArOZGChodNsHtGM24HVrqVtesmLd

What you need to do is compare the connectors PIN FOR PIN to the battery monitor and Pixhawk.

Thanks for the suggestion

Gonna try that out, and it that doesn’t work I’ll look for a new one,
probably something like an attopilot so I can know it works for sure

You need to compare each end of the 6 wire cable pin for pin.


Cable and pinout looks good.
But after removing he shrinkwrap I think I spotted the problem

Two caps seems to make contact because of sloppy soldering.
Might explain why PIN 4 gives me over 5.5V

But PIN 3 seems to work good though

Gonna try to fix that and see what happens

EDIT: Never mind, I looked at the old one and it doesnt matter if they’re touching since they’re on the same trace.
And I also tested PIN4 on the old Power Module and I saw that it’s on over 5.5V too?

I just checked a spare module, and with a 4S battery connected, Pin 4 reads 1.49 volts. With a 3S I get 1.21 volts.

I’m thinkin’ both of your modules are bad…

Yeah, already threw one away.

I’m not gonna cheap out on those next time.
It could cost me a crashed quad if I do :slight_smile:

After some research, I found that the power modules are not based on the open source 3dr power modules but something else, probably cheaper parts and stuff.

I’ll make sure to buy a genuine 3dr power module now

I’ve had a couple of these dud power modules. It seems the pin that should output about 1/10 the voltage is actually outputting Vcc. That gets multiplied be about 10 to give the 50 volts.

Not all cheap power models are duds though. I’ve bought a few from “wi-model2” on eBay and they have all worked fine and cost only £3.50.

I ordered one from wi-model2 and it’s now working!
This one had much more quality to it. Escpecially since it used silicone cables which the other power modules did not.

Now it shows correct voltage!

Glad to hear it :grinning:

I’ve had 3 from that supplier and they have all worked properly.