Servers by jDrones

Issues with OmniX config

(Reza) #1

Hi, I’m back trying to get my omniX rover to work, and am still having issues with getting any motor response. I’ve set up the rover, as the process has been mentioned but get no response.

For example, I tried arming the rover in manual mode, and then moving the yaw stick back and forth. I get no response from the motors, and looking at the logs, it is clear that it receives the rc signal, but sends no servo response.

I was wondering if any one had some solutions to this problem. I am loading both the tlog and the parameters file, in the hope that it may help. omniX.param (14.0 KB)

2019-05-24 11-45-06.tlog (230.2 KB)

(David Boulanger) #2

Safety switch maybe. I keep seeing the (SAFE) on the HUD. I’ve never seen that and I don’t use a safety switch so maybe that’s it.

(Reza) #3

Tried unplugging the safety switch, but that doesn’t seem to make any difference.

Here’s a tlog of that:

2019-05-24 14-01-33.tlog (340.1 KB)

(David Boulanger) #4

I think you would have to change BRDSAFETYENABLE to 0 also. can you put up a .bin log?

1 Like
(Reza) #5

You’re right, it works now! Thanks so much, I’ve had this problem for so long and couldn’t get to the bottom of it.

1 Like
(Reza) #6

Now that the motors are working, there are a couple odd things that seem to be happening.

The first is that when the throttle is forward, only motors 1 and 2 turn on. For everything else, all three turn on.

The second odd thing is that it seems I can not reverse. Is there some parameter that I need to change for that to start working?

(David Boulanger) #7

I know absolutely nothing about the OmniX configuration. I’ll look at your parameters again and see if maybe its in a calibration or something.

(ahmet omer ozgen) #8

It is probably a bad radio calibration. If you don’t center the thr, you can’t use reverse

(Sebastian Schürmann) #9

If you say “all 3 turn” do you mean you only have 3 motors? This would be a omni3 rover, not omniX.
No matter what config, all three inputs should come from spring loaded, self centering sticks. I always interchange RC_Map throttle and pitch for my rovers.
Make sure you have your radio/rc_map setup like this and redo the radio calibration.

(Reza) #10

When you say if you don’t center the throttle, do you mean when calibrating to put the lower limit of the throttle at the center not all the way at the bottom?

(ahmet omer ozgen) #11

Nope you shall move to maximum positions (including the pit trims etc) and lowest positions etc.

Then before clicking okay make the throttle centered. If not, (if you leave it at the minimum) your manual mode will only let you go forward.

1 Like
(Reza) #12

Ok, I calibrated the radio using mission planner, instead of qgroundcontrol and that’s done the trick. Thanks for the help!

1 Like
(Reza) #13

I am still noticing that when moving the throttle, only motors 1 and 2 are active, and that while turning (roll) only motors 3 and 4 are active. Is this by design or is there something wrong with my set up?

Perhaps @Ammarf or @rmackay9 knows?

(rmackay9) #14

@RezaB,

If this is an OmniX then all 4 motors should spin when the throttle is raised (or lowered). Probably best to post a dataflash log (to be clear, not a tlog but a dataflash log)

(Reza) #15

Here is the dataflash log, i hope they can help!