Servers by jDrones

Issues with arduplane v 4.0.9 and channel 3 output

Hi, I am using arduplane v 4.0.9.
I cannot calibrate my ECS, its a Volantex. Its on channel 3.
I am getting reaction on channel 3 input, and output.
This is clearly visible on the status page in Mission planner.

I have tried do disable the safety switch with arming reqire = 0 since I am indoors.

The plane arms according to mission planner.

Still I can’t calibrate the ESC.

What is wrong ?

Good day,
did you perform the calibration of the RC before calibrate your esc?

Yes. All other channels like rudder, balance, and so on works.

what kind of esc you own?

What Flight Controller?

It’s a Volantex RC 40A Pro Switch-Mode BEC Brushless ESC, the controller is a Pixhawk 4. The transmitter is a Frsky X10 running open TX. The receiver is a Frsky X8R.
I am running telemetry to the X8R, and 433 MHz radio telemetry. I have a voltage/current sensor from holybro, and also the “UFO” shaped GPS receiver.
The plane is a Volantex ranger 2400 with the mentioned ESC/bec that came with the plane.

Could I take a look at your parameter file? I have a Pixhawk on the bench with a motor running Plane and have some trouble myself with throttle that has me scratching my head…

Yes.

params.param (18.7 KB)

Perhaps I don’t understand your configuration. Throttle input is mapped to Chan 3 (default) and SERVO3_FUNCTION is set to throttle (default). Where does Chan 5 come into play relative to throttle?

Oh, I meant channel 3. That gets input and output according to mission planner. Still I can’t calibrate the ESC. I have tried unplugging the power to the ESC ( keeping the Pixhawk powered by the current/voltage sensor board), setting the throttle to full , plugging in the ESC but no luck.

I also have tried to power the Pixhawk by USB, same result.

The mode is of course manual.

Bug report filed:

I am starting to get tired of this, as I can’t figure out what the issue is and there is no replies.

You have BRD_SAFETY_MASK set to 27 which is 11011. So no PWM output on SERVO3. You have ARMING_CHECKS set to 0 which is not recommended. If you want to disable to Safety Switch (which I personally do not recommend) that would be BRD_SAFETYENABLE set to 0. ARMING_CHECKS does not have anything to do with the Safety Switch.

If this does not solve the issue, please provide a dataflash log so we can diagnose what is happening.

That resolved the issue!
Thank you so much!
I have set the arming checks back to all.
And BRD_SAFETY_MASK set back to 27.
I hopefully now can go fly when the weather permits that.

Servers by jDrones