Issues with APM 1.4 2560

Hi I have recently returned to the UAS scene after a 2 year Hiatus.

I downloaded the New APM Planner 2.0 to my Win7 (64) machine and I have installed it

I however cannot connect to the board Over my Xbees or USB cable on the MAVlink side. I can flash the board no problems so I have now Upgraded to copter V3.1.5 But I still cannot connect, I’ve tried different Baud rates but they make no difference. It did connect (or seemed to) once but then failed.

I can use Mission planner and everything works fine on that so I am a bit stumped here as to why APM Planner does not work.

Any help would be appreciated. Any logs screen grabs that might help I am happy to furnish but I am just so out of practice here that I don’t really know where to start looking for the issues.

21/07/2014 - Update,

After several unsuccessful attempts with APM Planner 2.0 I changed the firmware and re set everything up in Mission Planner (MP). After a few successful flights I decided to give APM Planner another go and It connected first time over the Xbee’s ( I am yet to try USB). I really am not sure why this worked as I can see no obvious changes to the Comms parameters, unless MP added Drivers I did not have previously.

I realise that this is a bit of a orphan issue as very few will be trying to go from a system that has not been updated since mid 2012. So as a work round for the few that find themselves in this position MP might be an option.


I don’t suppose you still have the log files from when it failed? c:\Users<username\apmplanner2\log.txt etc? Flashing firmware over USB may use a different driver than the XBEE, but both should work without issue once the drivers are installed. Glad it’s working for you now though.