Issues installing firmware

Im having issues trying to install firmware onto my autopilot computer. i followed the instructions on and I’m getting a error message saying unable to open COM port.

Below is the output message I’m getting. Im using a macbook pro with the latest APM Planner v2.0.15.

Any help would be awesome.

Thank You.

Started downloading … Copter.hex
Finished downloading /var/folders/6g/zcz5_bs926bc3yybtjym6xvm0000gp/T/APM Planner.Mll744
Opening firmware file…
Hex file loaded: 245440 bytes
Unable to open COM port:

Have you selected the correct com port (see highlighted area in attached image)?

The image is when you have Advanced mode selected. I also updated the wiki see

I tried to select a com port but it doesn’t give me a drop down to select a com port.

Any suggestions on why this is happening?

Thank You,

You can check that your system is seeing the APM2.6 HW (I assume that is what you are using) by running System Information Application and browsing the connected USB device to see if it there. See image below

(It will look slightly different as my APM2.x was connected via a USB hub)

What version of OSX are you running?

So I’m running OS X version 10.10.1

when i look under usb device tree there is nothing showing for the for the arduopilot. which it should like the picture.

When i have it connected to the computer the lights are on the the arduopilot which shows that it is getting power from the computer.

I also tried this same process on two different computers.

Any ideas on why its not showing up?

If you have tried it on other computers and you made sure the correct device drivers where installed if it was a Windows box. The issue is probably HW failure

where can i find the downloads for the drivers?

If you install the Windows version of APM Planner 2.0 for Windows, it installs the correct device drivers for you.

So if I understand you correctly, I should install the windows APM Planner on my Mac?

You said you tried on two different machines, but not what type of machines. So assumed you may have tried windows.

The two different computers were both Mac’s.

As I sated here viewtopic.php?p=26981#p26981 It’s probably the APM2.x HW you are using has failed. Look-up 3.3V regulator posts as that may have broken.

Hope that helps :slight_smile:

Figured out the issue, I had a bad USB cable, man I feel stupid

No problem. Glad you fixed it. I’d like to say that I’d never over look such a problem. But that would be an untruth :wink: