Servers by jDrones

Issues compiling APM Planner 2.0.28-rc1 and 2.0.29-rc1 on Ubuntu 20.04

Hi,

I’ve been compiling APM Planner 2.0.28-rc1 and 2.0.29-rc1 on an up to date Ubuntu 20.04 LTS. After encountering minor problems with package dependencies, it seemed that everything worked well and I build the deb packages. Once installed, I experienced the following:

  • 2.0.28. I can download and install firmware. I can connect to the serial port ttyACM0 with a nice green stablilize mode but parameters are not downloaded and Frame Type screen appears blank and any further calibration is not possible. I’ve checked the serial connection with lsusb and defining rules in /etc/udev/rules.d but without further improvements.

    However using the app Image of Arne-W
    https://github.com/ArduPilot/apm_planner/releases/tag/2.0.28-rc1
    everything seems to work fine and currently I’m using it. :slight_smile:

  • 2.0.29. I’m experiencing an issue in the Initial Setup screen. The window has no scroll bar on the right and I can only see half of the status info box, without the possibility of going furder down :frowning: . I don’t know what happens with the firmware nor the connection to the ttyACM0 seems possible. When using the app image of Arne-W:
    https://github.com/ArduPilot/apm_planner/releases/tag/2.0.29-rc1
    I’m experiencing the same issue. The screen resolution is 1366x768 (16:9) on an Acer Travelmate B113 series.

Hi @JosepJM,
thank you for the info and sorry it took so long to get an answer.
Due to the redesigning the setup several window sizes were changed. It could be possible that there is a problem with the resizing. I will have a look and inform you when you could try an new build.

Thanks @Arne-W and don’t worry, your app image 2.0.28-rc1 is working fine for now :smiley: thanks again !. Under what Linux distribution was it compiled ?

Hi @JosepJM I build a DEV release for you so you can test if you have a scrollbar on the setup screen.
You can find it HERE

Should look like this:

If you have problems with the ttyACM0 device try to start the planner with sudo. If it works using sudo you have to check your udev rules to get it work without the sudo command. On my system I don’t have a special rule for my Pixhawk.

The Appimage was build in a dockerized ubuntu 16.04 with Qt 5.12. Nevertheless I can build it on ubuntu 18.04 and 20.04 using Qt5.12 without any issues.

Hi @Arne-W, the scrollbar works great. Now the page is fully accessible !

However the link issues still persist. Using your 2.0.28-rc1 appimage I could connect without problems and I uploaded the firmware apm2-quad v.3.2.1. Now I tried to connect using your new 2.0.29 appimage (without uploading a new firmware) and, as I commented in my initial post, again the connection seems successful. Again it appears the green box and the stabilized mode at top. Moreover the serial connection seems right since I’m reading the same values as when plugging the flight controler using your 2.0.28 appimage, besides there are no errors in the var/log files. This is, the connection procedure seems is working iddentical in both cases. However in the 2.0.28 case immediately there appears “Downloading Params” and the bar progressing at the bottom left of the SetUp page while in your 2.0.29 app versions (and in my compiled 2.0.28, 2.0.29) this procedure doesn’t start. Checking the log file I see a repeating: “QCCParamWidget: No parameters, re-requesting from MAV”, “src/uas/UAS.cc 2254 LOADING PARAM LIST” and “ApmSoftwareConfig::populateTimerTick() - No Param names from param manager. Sleeping for one second”.

These are the messages that I also obtained before initiating this thread, besides, I also had tried starting Planner as sudo and changing udev rules. But, when working, the connection result looks always the same, and I belive, that in fact, it is right. At the moment, with your 2.0.28 appimage everything is working without any special rule as it happens with your Pixhawk.

I’m very new in this hobby and I have just the experience of few weeks wich mainly I spent reading and seeing many things when I had some time, but I’m pretty sure that with a Pixhawk I wouldn’t have this issue. My flight controller is a (very cheap…) Ardupilot, labeled “Arducopter”, v2.8 with few information in the web and not always positive… The lsusb command and the log file reports and Arduino SA Mega 2560 (CDC ACM) Product 2341, vendor 0010 but it doesn’t look Ardupilot original… Anyway, I hope to have time to continue in this nice hobby and to buy a Pixhaw in the future !

I have a question about the firmware that I’d like to ask you. You changed the Install Firmare screen display from 2.0.28 to 2.0.29. In 2.0.28 it was a matter of choosing the figure of the copter while in 2.0.29 the firmware has to be selected form a list. I know that your 2.0.28 installed apm2-quad v3.2.1 in my FC. However, in 2.0.29 this firm is in an hex file and now, thanks to the scrollbar :smiley: , I can see the status info box saying that hex files need of external tools and only *.apj or *.px4 can be flashed. Is there any reason for that ?. Also, I like the current firm I have since it seems it is working fine (although still I’ve not tried to fly…), but, could I also use a PX4 one in my FC ?. In this case, do you know which PX4 should be most appropiate ?

(post withdrawn by author, will be automatically deleted in 24 hours unless flagged)

@JosepJM @Arne-W hello
i tried installing both versions of apm planne in ubuntu 18.04:
in 2.0.28 : I encountered a problem in 'install firmware ’ screen which is blank in both disconnected & connected state (I’m trying to configure my pixhawk1 for the first time)
image
in 2.0.29: i have a problem to install firmware I load ardurover but when I connect the card there is the copter which appeared
image

Servers by jDrones