Issues after upgrading to V4.3.3


After upgrading my Pixhawk to V4.3.3 and Mission Planner to 1.3.79, I am facing specific issues I did not encounter in previous versions.

  1. The battery Voltage varies - A fully charged newly purchased LIPO 3cell is 12.6V. The voltage checker (tiny one) shows approx. 12.58V. Whereas, Mission planner shows up the voltage as 12.35 V.
    2 - Voltage variation at load - Voltage of 12.35 shown at the turn-on of the Drone, drops down to 10.51V even before the drone takes off but slowly under throttling up. Practically, this is not a matter of mission planner or ardupilot, however, with the same battery, I never faced this issue.
    3 - Voltage variation at no load - Observed a lot of voltage variation at the time of no load. The drone is connected and we are just configuring some settings. The voltage shown by the Mission planner varied from 11.8V to 12.2V
    4 - The EKF Failsafe - After upgrading, we have always seen this error of Position Estimate Needed. And whenever we flew it, it always landed back in seconds.
    5 - Position error - It is relevant to the above error. The configuration selected in the settings is X-type Quad. The Map shows the Forward direction line - Red and orange are together (however, it is straight toward one of the arms. This is not possible in X type, as the flight controller is in the centre, straight in between the two motors.) Also, the black line is at a different angle. Please check image for the reference.


Note that, we have tried to identify the battery issue. The same sort of voltage variation is shown even on QGC. Additionally, we tried the same thing on Cube with MP and QGC. The same happens in both the FCB.

Overall, we want to resolve the EKF issue which is crucial as well as the Battery issue too. Mainly because with this much of variation in voltage, we can’t really understand the exact critical low voltage for RTL.

A sincere request to help you.

Thank You

The battery issues you described are due to the battery itself, has nothing to do with the firmware.

As the battery ages these symptoms become more pronounced.

Regarding the copter symbol in mission planner , that is also normal. Quad +, Quad X, octa, deca, etc all frames use the same symbol, it’s not a bug, it’s a non implemented feature

The EKF issue is something that was not tested in previous few versions, that does not mean that the issue was not present. Just means it was previously undetected.

Please follow all the tuning instructions and post the results.

Thanks for your faster input.

As mentioned in the first point, the battery is a newly purchased one. After charging, the voltage checker shows 12.58 Volt. Whereas, the MP shows 12.35V.
Also, this can never happen with all the different batteries that I use. I checked with the 4S Lipo, 4s Li-ion and 6S li-ion. Things remained the same.

For EKF, I do not know if the issue was there, but we have flown multiple full-fledged flights under the previous version with all different batteries and different frames. These things never ever took place.

I will go through the Initial Tuning. I know the process. But will go through it completely to resolve it, step by step. The curiosity is, WILL THE TUNING PROCESS PROGRESS, UNDER EKF FAILSAFE? The drone automatically comes to land.

Thanks for your ASAP response.

The battery voltage multiplier parameter must be changed to correct the small voltage delta that you are seeing.

The EKF issue can have multiple reasons. It can only be diagnosed afert you:

  • perform mandatory initial calibration
  • perform battery voltage calibration
  • perform dynamic notch filter calibration
  • perform a small test flight and post a .bin log file

Finally, with the reduction in the wind speed, I was able to test it out today.

All the mandatory calibrations were done

Initially, it was oscillating from center to left, left to center back and then there was altitude increase and decrease.
After testing the same twice, I followed the ATC_RAT settings as mentioned in the initial settings page of ardupilot and reduced all the parameters of PID to half the current value. It was observed that the oscillations have reduced but not the altitude variation. After landing, again wanted to take off in stabilize and test Alt hold. But the moment I wanted to take off, it flipped forward and broke one propeller pair. Further testing of Alt hold is still pending.

Kindly go through the logs and see, if you can help.

Link - March 2023 Logs - Google Drive

Thank you

@amilcarlucas Requesting for a help.
I have posted a bin file for you to go through and suggest the changes. Kindly use the same link for all the logs.

I have faced few other relevant issues. Something is really wrong and some mistake is there which I am not able to identify.

Waiting for a speedy solution to this.

It’s not flying in this log. Why don’t you reset to default and start over.

Do you mean, it is not flying in both logs? How is that possible? Are both the logs empty (without flights)?
Actually, we flew it to a meter and then with a lot of oscillations, landed it. Changes are made and again done the trial.

I have done the reset as suggested.
Facing a couple of issues

  1. ESC continuously beeping.
  2. FS_THR_VALUE setting turned difficult. Mainly because the RC turn on and turn off both the THR Value is the same at 982PWM.

So, after resetting the FCB, I did a flight today.

No there are few confusions relevant to the understanding I have got from Ardupilot Discourse and what’s happening on the field.

  1. My quad takes-off. It keeps on moving here and there. Normally going forward-left direction. Also, keeps on increasing and decreasing the altitude.

Now, the questions are,

  1. Do you consider this moving of drone anywhere as an oscillation?
  2. I have gone through this initial tuning - Initial Tuning Flight — Copter documentation. Here, it says, if there are oscillations, reduce the values by 50% PID for Roll and Pitch and keep on decreasing by 50% of the value.
    Whereas, in Manual Tuning - Manual tuning of Roll and Pitch — Copter documentation. It says, Reduce the PID to 50% until stable and then increase.

So, I am not able to understand whether the movements are oscillations? or what happens when I move, is an oscillation? Like, I give Right (Roll), it goes right with jerks (then it is an oscillation?)
And then which method to be used to reduce the oscillations?


So post a link to .bin flight log.

Yes. The logs are here. March 2023 Logs - Google Drive

In case you find one or two tiny falls in altitude or crashes, it is just related to the propeller removal once mid-air, at low altitude, with almost no damage.

Do not post multiple logs. Post a single log, and the timestamp where the problem occurs!

Or do post multiple logs, but tell us which single to look at, and the timestamp.

Please help us help you.

1 Like

I see. Will keep this in mind for the next time.
Actually, I just found this movement issue on all the flights. So share all the logs.

Logs of 27th March are the ones we need to look into. That will be 4 or 5 logs of 27th march

I have updated the drive with only 2 logs.

Yes the motor outputs are oscillating. So, reduce the Rate PID’s by 50%.

Sounds normal in Stabilize mode.

Thanks for your input :slight_smile:

By Rate PID, you mean to say reducing
ATC_RAT_PIT_P/I/D and ATC_RAT_RLL_P/I/D by 50%. Right?

Also, I have a small request. Would you please share how did you identify that motor outputs are oscillating? Actually, I am curious to learn to identify the errors and want to resolve them further. Slowly learning actually. Because after this 50% reduction, I will again have to bother you.

Also, have a query. Do we really need to go with AutoTune?

Thanks for your time and quick help.


Plot the Motor Outputs:

You can graph the Attitude Rates also. RATE>R/P out should be <0.1

Yes. After the oscillation is gone, then the Notch Filter has to be configured and then Auto Tune.

1 Like

The attitude rates are “des roll” and “des pitch”.

So until I receive 0.1, I will need to keep on reducing by 50%?