Servers by jDrones

Issue with Zubax Gnss 2 GPS when booting from Batteries and not USB

Not 100% sure where to post this but…

I have a CUAV v5+ cube.

I bought the Zubax GPS

I have tried dynamic node and a static node # same results

Here is where it gets interesting…

If I power the FC with a usb cable tethered to the computer the UAVCAN compas shows up. At this point I plug in the flight batteries and unplug the USB cable and connect over a telemetry radio and life is good.

Please note
This is only for the compass. The GPS always works

However if I power up the FC using the flight battery and connect using the tele radio the compass is not there

This is repeatable and I have yet to have the compass show when powering with flight batteries first.

I also have a here 2 can gps/compass and this does not struggle with this issue.

Thoughts?

Thanks

Dave

So I found this on the Zubax site…

Anyone have an idea what this parameter is called?

This may be a non-issue at this point. Latest master ArduPilot has an added parameter that allows selection of boot time out from zero to 10 seconds to allow accessories to fully boot before the AP. Has worked well on all of my units tested.

Actually I found it BRD_BOOT_DELAY I changed it from 0 to 6000 and now the compass works perfect everytime

Servers by jDrones