Issue with Mission Planner Serial Terminal (CLI)

Hey all,

I am having some issues with the serial terminal in mission planner. I am using an apm 2.5 and connecting it to my pc using a usb cable. I have mission planner 2.0. When I connect I can read all my sensor data and see all the flight data. I can also change parameters. However, when I try to connect using the serial terminal, I get garbage on the screen. Basically random symbols. I sometimes get the screen where it tells you to hit enter 3 times to start the interactive setup. But when I do, I type and random letters appear on the screen! Does anyone know what the problem might be? I really appreciate your help!


Whcih OS are you using?

Please be aware that when you first power on the PAM you have 30 seconds to open CLI and press return three times before the CLI is disabled for safety reasons. (ie. the CLI causing a crash potentially)

I am having the same problem using APM2.0.8 on Win 7 pro 64 connected to APM 2.6 with latest firmware.
I can make terminal connection but screen output is using an unintelligible character set.
No response to multiple taps on the enter key - or any other key

Was there a solution here that didn’t get posted ?


Can you post a screenshot? Thx

I also tried the same operation on a different installation on a Win8 machine with the same result, tried different USB ports as well . ???


I have even just tried installing Ardupilot-Arduino IDE and tried the terminal connection through that with the same result.

Is this a firmware or APM hardware issue - how do I test for this?



Has it been working on these settings?
Has anything changed?
If I had to make a guess, and it is only a guess, but anytime I have seen that it has always been serial port speed mismatch.
I usually have to deal with it and bluetooth, what a horror story that can be.
same thing holds true for USB, I see your serial port is set to 57600
Mine runs at 115200 on a fresh install, so I have touched nothing. different people have different methods, but I would try setting the speed to either auto ( which should work ) or 115200 that mine is set to.
You will notice the output will change, hopefully one of them is the one you are looking for.
Serial interfacing always ends up confusing me, so I feel your pain.
Good luck

dowlinger has a sharp eye. The MavLink USB connection is made at 115,200 baud and not 57,600 baud as in the picture.
The MavLink radio telemetry connection is made at 57,600 baud.

Its the baud rate for sure. Its 115200 for USB connections.

PS: your signature says you are using AP2 RC5, but your screenshot shows the latest 2.0.8 version

Great hope it works.
I believe in pay it forward.
Now can someone help me with my " will not arm" issue? :wink:

Hi guys,

I am having a similar issue. I select 115200 and connect. Then when I click logs it always shows I am connected at 57600.

What is the correct process for dumping dataflash logs on Pixhawk with APM Planner 2?

p.s I am using version 2.08

Still not able to get a response to "30 seconds to open CLI and press return three times "

My status at the top right (next to connect button) displays COM6 / 115200

In Standard Parameters -/ Telemetry Baud Rate = 115200 for for both SERIAL1_BAUD & SERIAL2_BAUD

In the Terminal window I show COM6 and 115200 ( Note- COM6 is only available in the dropdown AFTER connecting to the APM)

After I click Connect the status on the lower left of the Terminal Output window changes from ‘disconnected’ to ‘Connected to COM6 : baud 57600’ even though the connection setup on the right show s 115200 baud

The terminal window displays output and doesn’t respond - as described earlier.

I can see no other options to effect the connected baud rate.

I have contacted Dany @CanadaDrones and had a reply to the effect that the APM may be questionable and is looking into replacement.

BTW , I also tried USB Terminal on my Nexus10 tablet. It connects but exhibits exactly the same behavior.

@Bill - updated my sig :slight_smile:

Thx all



Hi Chris,

I don’t believe the APM is the issue. In my case anyway (pixhawk) I am seeing similar to what you are seeing. I know the pixhawk CLI works as it functions correctly on Windows and Mission Planner.

It seems strange because as soon as I connect the pixhawk in APM Planner 2 and connect the terminal the garbage (mavlink packets) start coming in full and fast. There doesn’t seem to be any 30s delay or anything.

I note on Mission Planner when you connect with the terminal it sends a reboot to the pixhawk and I guess it then intiates the CLI as soon as the pixhawk boots up. And this works fine.

Could be possible that I need to connect the APM Planner 2 terminal at exactly the right time to get CLI working?

3DR approved an RMA on my current APM based on the issues I described so I guess we will see when the replacement arrives - soon I hope :slight_smile:


A new APM seems to have solved the problem in my case

Thank you advice offered.

CL :sunglasses:

Hey guys!
I have read the answers you gave, and i still don’t know whats happening with me…

It seems like the correct baud rate, but still don’t print the correct data.
Does someone knows how to fix it?

You are seeing MavLink data in the terminal.
As stated above, you have about 30 sec after boot to initiate terminal.

Mention of using the Terminal has been all but removed from the Manuals pages.

Thank you for the reply!
I have already tried this and the result was the same of the image i uploaded above…
Any other advice?

I have just downloaded the 3.1.5 version of arducopter and noe i get the correct data!
Thanks for the support!

CAn you post what you think is the correct data for others? Thx

That said the screen you posted look correct and shows the binary MAVLInk data after the human readable boot information has been presented. Nothing looks out of place.