Servers by jDrones

Issue with log review in Pixhawk

Hello everyone. Me and my coleagues wanted to log data from pixhawk to an SD card using “logger on” command in Mission Planner. After the logging we wanted to download data to computer using “Download data using MavLink” function in MP.
we have binary log file with, for example 5000 kB, but after we convert it to .log or to matlab file it has only 1-3 kB and has no value… When we want to review log in MP it shows the prompt that it can not be visualizes because it has no FMT messages… Can ANYBODY pleas help where is the problem ??

we tried different types of SD cards, formatting them, reinstalling new pure firmware and nothing works… i wanted to find log_bitmask, as mentioned in some discussions but in Standard Params i have no options to check.

The help would be very much appreciated, our work is stuck because of this logging issue. Thanks in advance to anyone answering

Hi Jakub,

You need to look in the “Full Parameter List” screen in MP and set LOG_BITMASK to 65535. The Logs section of the WiKi may help.

Welcome to the APM forums!

Hi Greg,
Thank you very much for your answer.
But the issue is that I can not find anywhere in MP LOG_BITMASK part. Not in Full parameter list, neither in Standard Params and I don’t know why. I have Advanced layout turned on. Pixhawk is connected to computer but it is still not there.
I am trying to resolve this for weeks but nothing works. I watched all forums but i could not find where could be LOG_BITMASK section. I tried the newest version of MP and currently I have 1.3.45 but it is still not there. When I click refresh params it will load something but no params show.

Did you load Plane or Copter firmware into the Pixhawk?

Those SDLOG parameters are from the PX4 Flight Stack. You are not going to find a LOG_BITMASK parameter in that firmware. If you plan on using PX4 you are in the wrong forum. Also, you will want to use QGroundControl as a GCS if you stick with PX4.

So you have 2 options. Go here for help with the fimrware you have loaded:

Or load Arduplane and then you will be in the right place!

1 Like

I loaded PX4 Flight Stack from QGC. And I have no clue why our binary log file after converting to log or matlab file doesnt have any data in it.

It can be a bit confusing, so I can understand your frustration. Basically whilst both ArduPilot and PX4 can be flashed to many of the same flight controllers, they are very different: so many of the tools are also different.
If you want to use and get the most out of MissionPlanner you need to use ArduPilot.

1 Like

I know it is different forum but still I am looking for help anywhere. Our work is stuck becaues of this issue and we have no idea why is it so that after converting the data file has no data in it.

I’d guess that Missionplanner, due to the issue you’ve already seen, didn’t parse the data from your log file - so nothing was converted.
To convert your existing log you’ll need to find a different tool. To use Missionplanner you’ll need to generate a new log using ardupilot.

Servers by jDrones