Servers by jDrones

Issue: RTK Fixed F9P Altitude Shown as Absolute/MSL

Hello!
Just upgraded to 4.0 and am excited to see there is autoconfig support for the F9P. I have a USV with a Pixhawk connected to a standard GPS and a F9P via SERIAL5. I have:

  • GPS_TYPE2 set to ublox
  • GPS auto configure is enabled

Boat is connected via UDPCI/Bridged LAN. I can inject RTCM corrections from NTRIP or a USB/Wifi/Bluetooth GNSS using Mission Planner - it works great. In this case, I have a separate radio sending corrections to the F9P and have a fixed solution.

Anyway, the issue is, In Mission Planner, the altitude never says “0” and instead displays my msl elevation. I’ve run into this issue before when the GPS doesn’t get a 3D fix until after the arming process, but in the case it occurs even when the pixhawk is rebooted via command (GPS not reset) and the F9P is powered separate, so is always providing a fixed solution. This was not an issue in 3.5.

Does anyone have any input? Any help is greatly appreciated!

Also, as a secondary concern but worth noting the F9P is also connected to an onboard computer running U-center via USB, I’ve noticed that after the pixhawk does its autoconfig (in 3.5 and 4), U-Center is very sluggish to respond. Does anyone happen to know what settings the pixhawk changes on the F9P?

Screenshot:

I’ve had a quick look at the altitude displayed in MP’s HUD and I see that it jumps to 980m for several seconds (I’m up in the mountains) but then drops back to zero. I’ve created an issue here to look into it.

I had a quick chat with our GPS maintainer (@WickedShell) and he said the full list is hard to give but it’s basically everything in this list. He suggested that although it’s a bit tricky the best thing to do may be to restore the GPS to it’s default settings, save the config, then let AP configure it and compare them. A bit technical but we support a number of UBlox GPSs and they’re all a little different so a definitive list is a bit hard to extract from the code.

Great, thanks! The one thing to note in my case, it never jumps back down to zero. With the standard GPS, it will jump and then return to 0 as you’ve described. However, with the secondary GPS in RTK Fixed, it does not ever return to zero.

Noted on the config comparison. I’ll get that worked out. It seems that after the config, I cannot read the parameters over USB anymore - it times out - but I can save config to memory, so I’ll do that and then pull them from the F9P over UART. Either that or workout from the list you linked to what the pixhawk is looking for and changing only the parameters needed manually and then disable the auto-configure.

Anyway, thanks for the help. If I find anything interested, I’ll post it here.

1 Like

You know what… Went out and ran a survey today…the problem seems to have resolved itself. Can’t beat that! Haha

1 Like

OK, so the altitude is dropping back to zero… I think that means that previously the EKF was not getting a good position estimate for whatever reason… I think in the previous state you probably wouldn’t have been able to use Auto mode…

One underlying issue is that Rover (unlike Copter) has both the EKF and the older DCM estimation system active. I’m considering disabling DCM completely but it is slightly more robust than the EKF in some unlikely situations. My personal feeling is that supporting DCM is not worth the extra complexity (which leads to a higher chance of bugs) but I haven’t quite made the leap yet.

Agreed - sorry for the false alarm and thanks for looking into it.

Servers by jDrones