Issue: RFD900x connection issues with Mission Planner

I am having an issue getting my RFD900x (Version 1.3) telemetry radios to work with Mission Planner/flight controller. I’ve had this setup working before but after switching computers and redownloading software/firmware, something has broken and I cannot figure it out.

  • I am running an Orange Cube flight controller with ArduCopter
  • Telemetry radio onboard has separate 5V power and I’ve checked that the wiring is correct (tx/rx)
  • When I power up the drone and plug the ground telemetry unit into my computer, both LEDs on the modems turn solid green and then at the same time, has the red LED blinking. Both of the units connect to the RFDTools.

Any help or suggestions as to what I could do would be greatly appreciated.

1 Like

Is the LED blinking red in a rapid manner, as if indicating data transmission? Is the green LED still solid?
I believe the recent firmware updates made the red LED more prominent - it’s always been there but just very hard, almost impossible, to see.

If you move the aircraft (or flight controller) does the HUD move in MissionPlanner?

The LED is blinking red in a rapid manner (I also read that that indicated data transmission) and the green LED is solid while the red light blinks rapidly. They have been updated to recent firmware as well.

I’ve only been able to connect to the cube by using a cable. This HUD works perfectly fine when using the cable but telemetry just times out when I try to connect.

OK, in MissionPlanner, make sure the Connect button at top right is NOT connected, and go to
Setup, Optional Hardware, Sik Radio
Do Load Settings and let’s see a screenshot of that.

If the air side radio is connected to Telem1 then show us your SERIAL1 parameters (or substitute whichever serial port you are using) such as:

EDIT: When you do use the Connect button in MissionPlanner are you selecting the USB/serial port that the ground radio is plugged into? and baud 115k ?

1 Like

Here’s a screenshot of the Sik Radio view in Mission Planner. As for the connection for MissionPlanner, I’m selecting the port the cable is linked to and using a baud of 57600.

Ah, the USB port is at 115k, the comms between the two radios is 57600.
EDIT: to be clear, they are like two separate things, you would always select the USB port at 115k
Try selecting the USB port at 115k when Connecting.

If you want higher data rates, for fast log downloads and so on, it’s safe to use these settings with those RFD900X radios and still get good long range.
Baud 115
Air Speed 200
Max Window 80
and set SERIAL1_BAUD,115 in parameters
Then everything is 115k and you cant go wrong :slight_smile:

1 Like

Okay so I tried to make some changes but nothing seemed to work. Let me try to explain what I did because it might have been wrong.

I went to device manager to look at the COM port the radio was connected to and this was the info. Baud of 115k

I then went into the Sik Radio section of Mission Planner and changed the baud rate, airspeed, and max window to the values above.

The onboard radio is connected to Telem1 and the ArduCopter settings for SERIAL1_BAUD = 115, and using MAVLINK1

Still will not connect :neutral_face:

1 Like

So after all that, the green LEDs are still solid, red flashing furiously like data transfer…
You go to Data screen in MissionPlanner, hit Connect for com7/115k and HUD still doesnt move with the aircraft and no changing values?

Try a different USB port on the computer too. You probably already did.

Exactly, I did try to change the USB/COM port to COM2 and still the same result. Should I try to change the ArduCopter software back to a previous build? I had these telemetry units working in the past on this same setup.

Don’t know if it means much but I went ahead and tried to connect on QGroundControl without the ability to connect the vehicle through telemetry either…

What SERIAL parameters do you have set?


Are there other parameters I should send values for?

Change the protocol to 2 = mavlink2
Also try BRD_SER1_RTSCTS,0 to specifically disable RTS.CTS

Okay I changed the Serial1 protocol to 2 for mavlink2 and I changed the BRD_SER1_RTSCTS from auto to 0 and I still did not have any luck. Should I try to reinstall mission planner or revert to an older build?

Sounds like everything works up to the point where the air radio connects to the autopilot. Maybe it’s worth double checking the physical connections again. Maybe a connector or cable has gone bad.

1 Like

Any chance you can try another computer with a fresh MissionPlanner install ?

At the Air radio (RFD) to Flight Controller(FC) wiring, is TX(RFD) → RX(FC) and RX(RFD) → TX(FC) ?

Copilot was correct in that after making another connector, a connection was made right away. The old cable must have gone bad as visually everything was okay (correct pins and no visual damage). I appreciate the help from both xfacta & copilot!

Now I can get back to trying to get this drone flying.