Servers by jDrones

Issue in my first mission


(Eduard cabanas Gili) #1

Hi
I loaded yesterday my first mission on my rover, but after arm the rover and confirm the mission, the rover started to make circles…and that’s it.

It could be possible that something is wrong in altitude? making circles, it feels like the rover wants to gain altitude.

Thank’s for your help

Eduard


(rmackay9) #2

Eduard,

It’ll likely be that the RC inputs and servo outputs have been reversed. Can you try using the Mission Planner’s motor test screen to ensure the wheels and/or steering servos are moving in the correct direction. I’m 90% sure that RC1_REVERSED is set incorrectly and at least one of SERVO1_REVERSED or SERVO3_REVERSED needs to be changed.

If that doesn’t work could you post a dataflash logfile?


(Eduard cabanas Gili) #3

Hi

The problem is that in manually works perfect. Today I reset again and the same issue, when I put in auto pilot, the car starts to run in circles.

I bought another pixhawk unit and the same result.

It seems everything is ok
image

I
thank’s


(David Boulanger) #4

Have you tried it steering mode. I think that will tell you if you need to reverse the steering output.


(rmackay9) #5

@ecabanas,

This is a very common issue so I’m pretty sure the advice I provided above will resolve it.

Have you tried the Mission Planner’s motor test screen? I think I provided a link above.


(Eduard cabanas Gili) #6

HI @rmackay9

You were right, now it works :slight_smile:

Thaaaaaaaaaaaaaaaaaaaaaaaank you very much

Eduard