Is this a 3.5.5 or Pixhawk 2.1 issue

I recently put together a quad using a Pixhawk 2.1 and 3.5.5. Got everything going without many problems. Specifically, that quad has ZTW opto ESCs with the red wire connected.

So I’m putting together the same frame and motors with another Pixhawk 2.1, but with HobbyWing Platinum 30A opto ESCs. Now the FC that came off the frame was a Naza and the HobbyWings did not have the red servo wire.

I also have a hexa with the HobbyWings and a Tarot ZYX-M FC and it does not have the red wires either. Both the Naza and Tarot worked fine.

With the subject quad, when I power it up, all I get from the ESCs is the beep indicating they’re not connected or receiving a signal from the FC. I’ve tried adjusting the MIN and MAX MOT_ parameters, tried calibrating the ESCs individually for throttle travel, double checked the wiring. Nothing is getting me going.

Has anyone run into this issue with 3.5.5/PIxhawk2.1 and these ESCs? I’d like to nail it down before I do a complete disassembly to solder in the red ESC wires.

On a separate subject, the Here GPS shows the flashing arm button, but no other LED status indications. My OSD is telling me the GPS has position though


Did you push the arming safety button?

I can’t get to that point if the ESCs are beeping.

To the best of my knowledge, all ESCs go through some power-on self test, which usually includes beeping the number of battery cells, in my case 6. Then they are quiet.

These ESCs never pass the self test and even after the Pixhawk runs through it’s power-on test, the ESCs will sit there and beep throughout.

My experience with esc’s and using pixhawks is that they beep while the drone is disarmed. Once you arm it they stop beeping. I haven’t had an esc beep out the number of cells and ive had atleast five different esc’s. If you arm it and the beeping goes away i would think you are good. But if you arm it and they keep beeping i would check the signal wire and its ground. On the pixhawk2 the ground wire goes at the top most row of pins and signal goes on the bottom row.

Did you try just using the ground and signal wires. Red is voltage and not needed unless your powering the aux. You can pull the red pin and tape it to the cable on the ZTW. You could try to reset using the Nase card with your current radio or edit the range in Baseflight or Cleanflight then install on the new FC. Good idea to have MP set the esc range at some point and do not forget to calibrate the radio.

If the pixhawk passes its own internal checks (after the flashing red and blue lights) and is flashing yellow, you can press the safety switch to send a signal to the ESCs. The ESCs should then emit the # of cells tone that you are familiar with.

The pixhawk does not send a PWM signal to the ESCs while the drone is diarmed. Press and hold the button and everything will most likely work well. The KDE ESCs that I use behave in this manner.

Gazer & Jose:
After a backyard diversion, I tried the arm button and yes, the beeping stopped. This does not happen on the ZTW equipped quad. That one doesn’t beep at all, unless I arm then disarm. Starts beeping 10sec after I press the button to disarm.

Yes, only using the ground and signal wires.

As of this moment, I loaded Arduplane and back to 3.5.5 copter to get a fresh start. Got too cold, dark and windy to run the compass calibration, so that’s for tomorrow.

Still no flashing LEDs for status though. Is this normal until I get usable configured frame? I just don’t recall these issues with the other quad, other than doing the compass calibration about 3 times.

Says who? If you don’t push the button the ESCs will NEVER get a valid PWM signal and they will beep until the battery dies…

Thought I clarified that in the post above.

Anyway, got a compass calibration done but with only the external compass being used and relaxed criteria.

The GPS puck still doesn’t show any status LEDs, but sure puts out some position.

Regarding the GPS status LEDs: do you have the GPS plugged into the GPS 1 port? Only that port has the LED output, except (I think) the USB port. GPS 2 and other serial ports don’t.

True opto isolated esc’s need power to the servo rail, and the 5V (red) wire connected, as the optocoupler is electrically independent from the rest of the esc.
It may be you need to provide power to the servo rail.

Yep, into GPS1 using that stiff ribbon cable that comes with the Here GPS. I might try to check continuity in the cable. I did plug the subject GPS into the other quad and the LEDs do work on it, so it very well maybe the cable.

It’s working now and the beeping stops once I press the arm button. Just strange that two frames that are wired nearly identical, behave differently. I have 5V available close by, so I can test that out.


Today, I swapped GPSs from frame to frame. The suspect GPS(call him #2) doesn’t show LEDs plugged into Pixhawk(#2), but does on Pixhawk#1 . GPS#1 shows LEDs on Pixhawk #1 but not on Pixhawk #2.

That’s telling me I have 2 good GPSs and there’s something going on with Pixhawk #2 not sending the signal to the LEDs to do their thing.

I checked cable continuity but it’s a moot point since I know GPS#2 LEDs work.

Try using a Telemetry Port. The GPS and Telemetry ports are just serial ports, so all you have to do is change the baud rate and protocol…


The kit did come with one of those Pixhawk cables that connect via the GPS2 and I2C ports, so I can look at it. That would come down to whether the GPS end was compatible.

Also can’t get any reliable data from my LIDAR using PWM. Range and voltages are all over the place. Probably not related other than in a systemic sense. Have a support ticket in with the vendor.