Is pixhawk 2.4.6 hardware reliable?

I have purchased six (expensive) pixhawk modules from a store recommended in the official pixhawk site:

From the six, three were faulty (as far as I can tell). I have configured all modules using the same config file.
One of the modules did not output a signals to the motors, while showing “ARMED” in the mission planner. I have verified this using an oscilloscope.
The second one did not boot correctly (the main led stays off when powered by the USB). The led light up when connected with a power module and a 3 cell lipo battery. But when I tried to connect the Lipo and then the USB (in order to connect to the MP), It stopped responding all together.
When using the third module I got all sorts of crazy behavior, and all sorts of error messages regarding the EKF and the magnetometers (link to datalog).

The other 3 modules worked fine, aside for one of them not outputting a signal on ch 2 which was replaced by ch 7.

My question - Is it possible (and where) to purchase a reliable pixhawk 2.4.6 / 2.4.8? Or is my only option to by a 2.1? IS the 2.1 more reliable?


It was my understanding that the mRo Pixhawks are good quality, but I’ll let someone with more experience with them comment. I have a lot of experience with the 2.1, though, and I think they are excellent. I recommend them for any aircraft that is large enough to fit them, or where safety is especially important.

Regarding your situation, though: you say you configured each Pixhawk with the same parameter file. Did you calibrate afterwards? You will still need to perform a calibration afterwards, as using the values saved by a different pixhawk won’t work, at least in the case of the accelerometers, and also the compass if it is a different GPS/compass module or configuration.

Yes, I calibrated the pixhawks individually. BTW, If you could take a look at the datalog I attached I would be very grateful…

In the log, it appears that the compass is misaligned (backwards?), causing the position estimate to diverge immediately. The commanded roll and pitch didn’t seem to move the drone in the correct directions according to the recorded heading.

I had similar problems with boards bought at the beginning of 2017 , but defective boards were replaced with new production batch in April 2017 and problem were solved.
So if you had purchase the Pixhawk recently it is quite strange since Mrobotics has put a great care in product quality control .
But if you read the Mrobotics blog you’ll understand that manufacturing these boards is a matter of details where the devil often hides.

Contact Mrobotics , I’m sure they will solve your problems, they usually gave a great support to customer.

1 Like

Anubis - I only use the internal magnetometer. I tried calibrating the compass in the field with no results. It kind of seem random - sometimes the pixhawk works OK, and sometimes not. Turning the drone 360 deg around the yaw axis after power up seems to help.