Servers by jDrones

Is it necessary to have the RC transmitter?

Dear community,

I’m trying to build a rover that can do automatic measurement and data collection work using Pixhawk. So basically what I want to do is to input multiple coordinates from mission planner so that the rover can go through all the waypoints and perform the measurement.

So in this case, is it still necessary for me to buy a new RC transmitter ?
Is there any way that I can caliberate the servo to be zero angle using mission planner?

All the suggestions will be appreciated. Thank you so much.

Best regards,
Mirko

The pixhawk can complete a mission even if the radio link fails but you must be able to “talk” to the FC to initially start an auto mission. You could use something like bluetooth/wifi to send a Mavlink message to start a mission I suppose.

Depending on the country you operate it might not be legal to fly without a method of manual overide like a RC transmitter. Oups… rover… Never Mind , you can let the robot on the loose… :slight_smile:

1 Like

It’s possible to use a gamepad (aka joystick) instead of an RC transmitter but I think you’ll find the setup and tuning painful. In practice, I think things will go much smoother if you just by a transmitter/receiver. There are very reasonable options out there ($70 or less) that will be fine for your needs.

What happen if you are riding and rc receiver died? Is like you don´t have rc transmitter, (NO RC INPUT) perhaps in rover only stop but in airplane or copter? It trigger failsafe or crash? Thank´s

@cala2,
It should trigger the RC failsafe just like it does when a regular transmitter is turned off. I haven’t actually tested the RC failsafe much but it should work.

Thank´s Randy, I´m going to try to simulate flying multicopter unplug receiver and report result, little more difficult to do with airplane but, if I can, test too.

1 Like

Hi there, Have you tested out using the rover without a transmitter yet?

I have been wanting to do this for almost a year with no helpful replies yet. Everyone just says it is easier with a transmitter. But what if I want to hike far far away with my rover, I don’t want the added weight of the transmitter, end of story.

So I ended up buying a Taranis Q7 something or other because I couldn’t figure this issue out.

Thanks!

Steve,

It should work without a transmitter. I guess you’ll be controlling it through a ground station. Some info that may help:

Not sure which ground station you’ll use but most have the ability to click on the map and make the vehicle drive to a specific location in guided mode. That should work fine but please ping here if it doesn’t.

I left the rover alone since November since I was frustrated. I came back to it last night, and uploaded new firmware (But I had to use some method another user came up with which was plug into battery, then into USB, send firmware, unplug USB first, then power, Then plug back in in the reverse order or something like that?), and now the rover proceeds on its own!!! This after I just spent ~$200 on a Taranis that I have now moved my frustration to.

1 Like

Steve,

OK, I guess that’s good news right? You wanted it to move without a transmitter right? sorry if I’m misunderstanding.

Uploading firmware to a Pixhawk (or compatible) should be pretty easy. Normally there’s no need to plug in a battery, the USB cable and PC should be able to provide enough power for it. The only times that it’s not enough is if the laptop/PC provides very little power to the USB port (which is rare) or there is a powerful telemetry radio attached to the flight controller that consumes a lot of power… more than the USB cable can provide.

I have a pretty large LiPO battery attached to the pixhawk and the mro telemetry system everyone has. I have also gone through about 15 USB cables and found 3 that work.

Even with all that equipment, it takes me about 20 tries before I can actually connect to the pixhawk and send firmware. Somebody online suggested attaching the battery AND the USB cable and unplugging them in a certain order, then back. This has worked every time since I found that out.

Steve,

OK, that’s very strange and unusual. I’m sure that it is not the case for the large majority of users. I think it would be good to try disconnecting everything from the flight controller (GPS, telemetry, receiver, battery, power module) and just plug the flight controller to your PC with a USB cable and then try uploading the firmware. I think you’ll find then that it works reliably.

Once this works, then try connecting the peripherals again one at a time until you find the one that is causing the problem.

I’m not an expert on hardware but I’m pretty sure this is a hardware issue or more accurately a power supply issue.

Steve,

I have had occasional issues powering a clone pixhawk via USB (no batteries) - it would light some LEDs but not fully boot up but rather stay in some hanging state with odds sounds coming out etc. I tried numerous short USB cables but always using an old 2m USB extension cable (USB 1.0 specs apparently) to extend the length. Somehow the poor specs, the intermediate plugs or something like that was preventing proper power flow…

What solved it for me was dumping all the old short cables and the old extension cable and getting a brand new microusb to usb cable from amazon for 10 bucks that plugs directly into pixhawk and laptop. works beautifully ever since - and that at 5m cable length…

… so in my case the root cause was inadequate cables… leading to what Randy stated - power issues.

Hope you find it soon, this can be frustrating - but it’s worth it once you overcome the issues…

Christian

I agree about the cables. I went through quite a few until I found some that could power the pixhawk. I have since labeled these, and tossed the rest. In addition, I think it might be my old laptop. I heard desktops work much better for power issues like these.

Thanks for your replies!

It actually can move without RC transmitter after I disabled the radio failsafe. However, the rover behaves very awkwardly and doesn’t follow the waypoints that I specified in the Mission Planner. Is it because I didn’t tune the parameters of the controller such as the PID values? If so, can I do it without RC transmitter?
Thank you so much!

Mirko,

It’s most likely that it’s a tuning issue and unrelated to the lack of RC input. If you can provide a dataflash log that would be best.

There are also some tuning videos on the tuning-throttle-and-speed and steering-turn-rate wiki pages.

Thank you for your help. I have done the wiring and installation and will be doing the tuning on site soon. However, after I read the tutorial regarding tuning CRUISE_THROTTLE and CRUISE_SPEED parameters, it says that these two parameters have to be tuned via Manual mode (which means RC input will be needed? )
So is there any way to tune these parameters without using RC transmitter? Thanks again

Mirko,

It’s possible to do without an RC… you can take a guess of a good value, then drive it around in Auto or Guided and then check the dataflash log’s THR message to see speed (which should go into CRUISE_SPEED) and throttle level (which should go into CRUISE_THROTTLE).

Thank you for all your help.
I did a field test days ago and this is the link where you can download the dataflash log:

https://drive.google.com/open?id=1jt7EN4-maYwxr5F3lXpjAkl1MNMCm8aM

I can’t really find the problem why the rover fails to follow the waypoints in the auto mode. Could you please give me some instructions to solve this issue?
Thanks again.

Servers by jDrones