Is APM 1 compatible with newest M.Planner?

I’ve been away for a while since last crash and now when I returned things has moved alot forward!
So many new things! (new operating systems) New board like APM 2 and 2.5 and this PX4, new forum, new store, new site, we moved! and so forth.

So, I’m running the sandwich APM1 Mega 2560 and are having difficulties with the +hexa setup.
I got APM1 + magnetometer, I’m waiting with connecting the (mediatek)GPS until this thing appears safely flyable.
Compass seems like it’s 130 degrees off.
When I’m trying to enter magnetic declination it erases my input of 4.46. I can enter 5 though.
Even though I’ve done the mandatory setups it refuses to arm unless I defeat arming checks.

What’s with the Calibrate Accel AC 3.0+? should I have that box unticked?

So… How do I go about setting up an AMP1 nowdays? Seems like I run into many many problems.

I do not believe that the hexacopter will arm without a 3D fix which requires a GPS to be connected.
How do you have the compass mounted? To get a correct compass bearing with the APM1.4, I believe the compass orientation should be components upside down and pin connections facing forward.

Yep, the compass board is upside down, soldered into place as the instructions said a year and half ago :smiley: the 4-pin connector facing APM "front"
I recalculated the compass declination and input it manually, I also seem in the process somehow to reset the compass orientation to somewhat correct.

Hmm… so new arming procedure might trip me up. It’d be a shame to not be able to use that handy feature.

A new strange issue appeared, my Turnigy Plush 18A ESC refuse to accept the “low” PWM signal -hence they beep beep beep beep beep beep 4 times a sec.
I tried to move the “low” setting with a manual PWM generator but with no luck.
Maybe I’ll have more patience tomorrow for that.

I downloaded a hexacopter hex-file for APM FW from a diydrone repository and used that. The old FW was not able to contact make contact the new mission planner, it kept saying “missing heart beats”.

Could things get more complicated? :unamused:

Any other pitfalls with new mission planner and APM 1? Anyone know?

How do I go about to use the installed Mission Planner(has 2.9.x?) but with 2.8.1 AC FW?
(As I gathered 2.8.1 is the last APM1 compatible version, true?)

There are several items in software that I can’t alter, it gives me an error message.
For instance I tried changing RC_SPEED from 490 to 400 to be compatible with unmodified plush 18A ESC, the MP replied unsuccessful in changing variable (or something to that effect)

To where do I unzip the 2.8.1 zip archive? or… well?


I im in almost the same situation as you. Had a 2 year “free-time” from this craziness :laughing: and is now back…
I bought my APM1,4 two years ago and soldered it together a mount ago…

I tried 2.9.1 and had bumpy loiter and a real big scarey flyaway, and some fun flying.
But 3.0.1 has been wonderful… Super-steady loiter. RTL, AUTO, Guided. and no flyaways yet :unamused:

But I also had big problems the first time to arm my Plush18a ESCs. The just went bepp beep beep beep.
Lik they had no connection or pmw-signal.
I got it working by manually calibrating the ESCs from my rc RX…

Try looking at the posts in this Arducopter 3.0.1 release for an answer to your cal issue: … e=activity

Thanks for you post.

My problem WAS not that my APM1 didnot arm, it was that the ESCs did not “armed” or played the “3-cell-tune”, they just went beep beep beep beep… like they du when nothing is connected to to the servoplug.

But after manualy calibrating them by plugging in one by one into my rc tx and turning them on with “full throttle” on the TX and then down, they got connection with the APM1 and now the quad flyes well… :smiley:

As a sidenote: I have not got the ESC CALIBRATION tru the APM1 to work. The one with booting the APM in esc-cal-mode and rebboting and so on. But I recond that the PWM values into the APM is almost the same as the PWM out so manual will do the jobb. My quad is stable and can do aggressive flying in acro…