IRIS+ irregualr throttle stick behaviour


I was trying to do a manual flight from my iris+. When I try to arm the quad it didn’t get armed and sometimes did. I noticed that the lower threshold of the PWM value of transmitter throttle stick was not uniform (sometimes it was 998, sometimes 1191 etc for the same lowermost point). I have tried RC recalibration.

After arming it also happened that 2 of the motors were starting late, so I also did an ESC recalibration, but after this again the quad didn’t get armed.

Can anyone suggest, what might be the issue here or how can I debug this.


When I try to do a motor test using mission planner percentage throttle to which motors responds to is sometimes 11% and sometimes it doesn’t respond to 15 percent.
Earlier the motors used to spin at even 5% throttle
I have tried adjusting the trim settings of the transmitter also.


ESC calibration allow the ESCs to learn the minimum and maximum value of the throttle. For example DJI has there factor set at 1000 min and 2000 max and therefore do not need calibration since there flight controller always outputs in that range.

If your radio is defective it maybe outputting fluctuating values causing this calibration to not work as expected. The PWM coming from the radio should stay at a constant value with a plus or minus of about 3.

This can be verified by looking at the radio calibration screen and see if your values are constantly changing.

You should not be using the trim tabs on the radio as this confuses the flight controller and ESC calibrations.



When I saw the calibration screen, the value of throttle at lowermost point was fluctuating. For example pwm value is 992 at one instant of time and when I move the throttle stick up and bring it down again it is 1100 something.

Also, at times when I quad did get armed the motors didn’t spin till I moved the throttle stick to about 1/4th of the full range.

Is there any way through which I can figure out whether the issue is at the receiver and pixhawk side or transmitter side.

Is there anything that I can try looking up in the transmitter, because I have been using the same transmitter regularly for the past 8 months, infact I had a successful mission, just a day before this random behavior cropped up

More than likely the stick has gone bad or has a bad spot in it. If its only that one item that is doing it and only at the lower end then the stick has a problem. Some radios have a debug mode where it will show the stick values as you move it up and down. You might also be able to replace just that stick based on what radio you have.


So here are a couple of things I tried:

I binded the receiver of the iris with a new transmitter (This transmitter has been working fine with another iris and doesnt have any throttle stick problem.)

I got the same result, where motors wont spin after arming or in ESC calibration mode unless I raise the throttle to about 40 percent.
I mailed to 3DR guys, they suggested that I upgrade the firmware and reload default parameters followed by calibration. I followed this procedure but this didnt lead to any success.

Any idea what might be the problem with the hardware or can I still try something with software. All the motors at 40% throttle only. It seems highly unlikely that there is an issue with ESCs and all 4 ESCs will start behaving in a faulty manner.

Please, any suggestions?