IR-LOCK not working in copter 3.53

I am connected to i2c on pixhawk as per instrctions plnd parameteres are all set.
The error I get is “Bad vision position”.I downloaded a data flash log and it read
heal=0,tacq=0.It si not communicating with the pixhawk.Is there something missing in
my settings.Also,Do I need sonar or lidar to make this work?

Which pixhawk are you using? Ph1 or the cube? If it’s the cube, make sure you configured the interal I2C bus.
Yes, you need a rangefinder attached in order to get Precision Landing enabled.

1 Like

I’m using PH1. But, I dont have rangefinder installed.Can I use Maxbotic 1240 or do I need something exotic
to make this work.Also,Should I use internal I2C?Is this why I’M getting bad vision position error?

Precision landing with IRLock only works if you have a rangefinder connected (laser or sonar).
Moreover the I2C port can be changed in the PLND_BUS param but you shouldn’t have to change it normally.

1 Like

Technically, any rangefinder/sonar will enable the precision landing to function. However, we recommend the SF20/LW20 units, due to their accuracy and robustness against IR interference.


Thanks ThomasSFL.
I appreciate your response.I will look into aquiring a SF-20 in the very near future.

Thanks for the input.I’m looking into getting a rangefinder.

Whoops sorry for digging up an Old Thread.
Anyone tried the SW11/C connected to the I2C Bus with IR-Lock?

I am currently occupying all my serial ports with none-left to spare.
The SW11/C is due to arrive in a couple of days, just wondering if any has any experience with the I2C Setup!

Thanks everyone!