IR-LOCK - make precision land not stop following the target

I am using IR-LOCKwith default setting from firmware 1.0.1 … with MarkOne 3.0 IR target.

The issue is that at higher altitude (10m) the target can move quite fast, and copter follows fine.
As the altitude decreases , the targeting is too slow to keep up.
At a certain low altitude, tracking stops, and the copter lands vertically where the target have been.

Example: target is drifting slowly at 5cm/s … the approach and descend is fine, but at about 50cmAGL, the copter does not longer try to keep the target centered, and just lands vertically.

I did try to mask out the IR_LOCK to only four LED’s - so the beacon is not too big/fills the sensor.

How can I make the following more aggressive(correct faster) at lower altitude , and - remain following the target all the way to the ground ?

@ThomasSFL - I guess you have some appropriate tricks ?


Are you using ArduCopter 4.1.0-rc3? I think there is a compile time define for that minimum altitude, you could reduce that and recompile the code from source.

@amilcarlucas Perfect ! - exactly what I suspected, - can you give me a hint where it is? (or what the default I should search for is called?)
BTW: right now I am using 4.1.0-rc2 - but will pull now.

look in libraries/AC_PrecLand directory

@amilcarlucas Sorry for not being clear.

I did already check all files in AC_PrecLand, not only those for AC_PrecLand_IRLock - I also checked precision_landing.* - but fail to see anything that inhibit lateral navigation at low altitude.
I expected to find something that makes it just sink vertically when descending below 40/50cm or so.
Then I checked again, even diffed between 4.0 and master/4.1 to spot significant changes.

No luck. apparently this code is invisible to me. :slight_smile:

@ThomasSFL Do you have any suggestions ?

@amilcarlucas - please help me find it … I had no luck finding such setting.