IR Lock and Pixhawk Error: Bad Vision Position

Hi guys,

I can’t for the life of me get the IR Lock sensor to stop giving the above error. I’ve checked that the i2c cable is okay and have a sonar rangefinder connected that is working OK. The Pixy cam detects the IR beacon just fine when I connect to it via USB and PixyMon. I’ve tried each of the PLND_BUS parameters (default, external and internal). I’m using an external I2C splitter but I’ve tried connecting the Pixy directly to the Pixhawk as well. Still no luck.

I guess at this point I’m on the verge of just giving up. Just wondering if one of you guys have something else I can try?

Much Thanks

Usually that is the error you get when PL is enabled and for some reason ardupilot can’t see irlock.

Make sure connections on the I2C bus are correct.


It seems to working now. Had to load an older firmware version onto the Pixy and that seems to have done it. No idea why though.

Hey, Can you tell me the firmware version of pixy cam that you have used?

For anyone struggling with this sort of thing, make sure the communications bus on the pixy is set to I believe ‘1’ for I2C. Configure the pixy with PixyMon over the usb cable.