"Invalid Waypoint file" when loading a custom-made waypoint file

I am trying to format a .txt or .waypoint file that can be used in mission planner. I am having a hard time figuring out where my formatting is going wrong because every time I try to load my custom generated waypoint file mission planner gives me the popup window that reads “Invalid Waypoint file”.

Here is my file output: which results in the “invalid Waypoint file”


Here is a similar generated waypoint file from MP:

The above file works just fine when loading it into mission planner but the file that I created does not work. I am using ‘tab’ as my delimiter as requested by mavlink documentation File Formats · MAVLink Developer Guide

I am unsure where to go from here. Does anyone see anything wrong with my formatting? Any suggestions on what I can do to get my generated waypoint file to get accepted by the MP file select feature for waypoint missions.

On the first line
'QGC WPL 110"
You have to use spaces instead of tabs.

1 Like

Thank you very much. Just tried this and it worked perfectly!