Invalid argument error when starting Plane SITL

I’ve been trying to use Plane SITL using the “Start SITL” button on the simulation page on Mission Planner, but I get a invalid argument error when JSB sim starts, and the simulation fails.
The strange thing is that it has randomly started once on my laptop and desktop, both are Windows 10.
The other three platform types, Rover, Multicopter and Helicopter all work flawlessly.
Has anyone else experienced this or might someone be able to explain how I might go about trouble shooting this? Thanks :frowning:

Any suggestions anyone?
I’m not a software person, but I can see it’s something to do with how JSB sim is set up to communicate with the simulation software.
Could it be a Windows 10 issue?

I’m seeing the same thing. I was able to get it to run one time for unexplained reasons but never again. I would appreciate any insight.

Could it be a Windows 10 issue?

Great thought but I just tried Windows 8 and same issue occurs.

What I’m noticing is that it starts to yaw as soon as the params are finished loading. So I got the thought to load some params manually and see if it stops. It certainly slowed the yawing down but did not remove it. So I think it is somewhere in the mav.parms file. Mine says it loads 631 params so no idea how to isolate that to a manageable level.

I am also see the problem with yawing. I thought it may be some problem with latest build of ArduPlane (3.4.0) that there is some bug in code but i tried to run version 3.3.0 and one more earlier with the same result that plane was rotating in yaw. I also tried to change parameters in Mission Planner but I achieved only slower yawing nothing more. At this time I can’t make it run properly and simulate anything.

What more I tried to run Copter simulation and everything was perfectly working.

I am realy looking forward for someone to fix this :slight_smile:

At the very least it would be nice for a bug to be confirmed so we don’t keep spinning our wheels thinking we have done something wrong. I am not familiar with all of this enough to be able to do that myself.

I just updated mission planner to the latest beta and managed to get the simulation to load and start, then plane crashed and the simulation froze, and now the invalid argument error has returned and the simulation won’t start.

This issue is more a Mission Planner problem. I’ve sent a link to this discussion asking them to have a look.

FYI I tested and did get it working with JSBSim.

Thanks, Grant.

1 Like

Could you tell what have you done to make it working? I tried to build everything by myself and run it without Mission Planner and plane still had rotation in yaw. Is there something to be changed in JSBSim?

It would probably help some people to know how to fix it :slight_smile:

To be clear I’m not sure how MP interacts with SITL. However, if I see that sort of yawing behaviour when I’m running SITL on Linux I immediately wipe all my parameters and waypoints etc and start again and that resolves the issue. Once you have SITL running if you go to config/tuning in MP and select one of the Full Parameter options and click “Reset to Default” and see if that helps.

Note if this was under Linux and I was using sim_vehicle to run SITL I would pass it the “-w” flag. So -w
and wait for it to finish and then run SITL again. Just incase anyone needed to know how to do it under Linux.

Thanks, Grant.