Internal error on old pixhawk 1

Everything on my pixhawk 1 works well, as far as I can tell, but the HUD shows a flash of this error code every few seconds:
internal error 0x3000 I:1045 lomou_reset

Anyone know what this means?
I’m running the 4.1 version, and the latest stable MP
Insufficient memory problem?

Try latest master. and provide dataflash logs

amilcarlucas, the error message is preceded by:
Pre-arm:------- so there are no dataflash logs, --or I don’t know how to get them from a disarmed pixhawk. Can I set the parameters to just log in all states? How to do this?
I will try latest master now.
Thanks very much

set LOG_DISARMED parameter to 1

But do not forget to set it back to zero once you get the log

Great! Will do. Then how to attach logs here? I’ve never done that before.
EDIT: The wiki got me through loading the .bin file onto memory stick, but when I try to upload it here, it’s too big. I don’t use a cloud service-- is that the next step?

Use a cloud service like

Thanks for your patience. I’ll set up an account, if necessary, and upload to the public file.

Wetransfer seems to require recipient’s email. I set up the account- free one, since I rarely use such a service. But it seems unlikely that email is a good medium for largish files. I’ve got a dropbox account that seems to make more sense-- I’ll upload the .bin file to the public file.
Am relearning this stuff on the fly.
Thanks again.

wetransfer allows you to share an URL. Use that.

(Twenty characters it will be.)

Thanks for pushing me into learning something new.

If it’s an old Pixhawk 1 with 1Mb memory then you would want the Pixhawk1-1M firmware. You are using Pixhawk1. I have one of those Flight Controllers and have seen odd error messages and random USB disconnect if the wrong target is flashed.

Thanks a whole lot, Dave. I bet your’e right! It is an old pix.
I owe you.
Will trade out the firmware right away.
Thanks, amilcarlucas also.

Well, I loaded the proper(other-1 meg) firmware, and tried to arm. Now I have the same error message, only constant. If it was just that occasional flash, I might go ahead and fly, but I can’t arm.
Nice try , but no cigar.