Intel D435i & Raspberry Pi 4 with Raspberry Pi os

Hello all.
I am trying to follow this site:
I am having some trouble getting packages installed for the intel D435i on the raspberry pi with raspberry pi OS (I tried Ubuntu and had the same issue when it came to pyrealsense2)
Now the picture above, where do these get installed into? currently, they are being put in the location /home/robox/.local/lib/python3.9/site-packages by default, with no mention of where these should go.

I have been able to make it as far as the pyrealsense2, however, this reports that there is no version that supports my OS.
I tried to follow the below to build it from source and hopefully get the python files I need but it doesn’t make sense to me.

Has anybody got this to work and have a step by step n00b guide that includes all the details?

I would be very appreciative of some help on this, additionally, I will try to get it to work on the Jetson Xavier NX.



Hi Phil, this is Craig. I have spent the last week in utter
agony trying to get Pi4 set up to run D4xx_to_Mavlink - from Vision_to_Mavros. You
have no idea how many problems there are with the blog posts
on this. I believe I have worked through the problems and I now have the
video of the depth display working on my PI the only issue
is that the PI is seeing my USB3.0 cable as a USB2.1 cable
and the feed from the camera is slow as a result and the
program is halting after a while. This is a hardware issue and
at worst something I have to adjust in the script, Anyhow my system
appears to be setup correctly, all the packages are loaded
properly and the correct flags for the critical OPENCV package
compile were set I beleive properly. Give me a private email and
we can discuss this, it would be good for me
to have someone else in the trenches with me that I can
bounce problems off of when they arise. I did maintain
a build log.

Hi Craig.

I have moved on to the Jetson Xavier NX, I am almost done, just need to figure out why I am receiving the error Device /dev/ttyTHS0 is dead.
I’ll get back onto the pi in a week or so and see if I can get that going.


Good luck Phil, I hope you get it. I am returning to my work
tonight to find the freeze in the d435 depth image on the rpi4.
The good news is that one of the examples is working for me without any freeze so I just have to backtrack and figure out what it is in the code that is making it freeze. Hope to have that done this weekend. My RPI4 is also not seeing my camera as USB3.0 while the realsense-viewer is seeting it as 3.0. Weird. Anyways I am digging in this weekend to get it all working and wish you success on the Jetson board. Let me know if you go back to the RPI4 and want to talk. Regards. Craig PS try arming or forcing an arm on your flight controller and making sure you are getting a connect message on mission planner messages screen then see if the dead port message goes away…Recall that you also have to set up the uart through mission planner to the correct settings as well. good luck.

I have been able to get depth data through at last.

  1. had to disable nvgetty as this was holding /dev/ttyTHS0
  2. turns out my scope was set to the wrong setting and was holding the tx from Jetson high.
  3. had to change the timer in d4xx_to_mavlink to 20 seconds from 5 as the camera is taking longer than 5 secs to respond.
  4. couldn’t get all the pyrealsense .so files and other bits unless I enabled

which I believe builds it with usb 2.0

I have created a complete guide for new installs, will follow it on a fresh install to double-check and give it a polish.

The Jetson froze when I ran the d4xx_to_mavlink not sure why and it only froze once, since then seems to be stable at around 30 - 40FPS on the debug window.

Congratulations Phil