Servers by jDrones

Installation Roadblock LINUX HELP

(Brier K. Fox) #1

I am literally stuck at what feels to be the very last step in getting qgroundcontrol installed and ready to go…
I’ve hit a snag using Linux that literally leaves me frantically trying to find the last command to install this software. I have everything downloaded, and the last thing I ran in to is it telling me it doesn’t want me running qgroudcontrol.install and the like…

root@rootwire:~/qgroundcontrol# ls
android HackAndroidFileDialog.qrc qgroundcontrol.pro
android_environment.sh HackFileDialog.qrc qgroundcontrol.qrc
android.pri installheader.bmp README.md
build_ios.sh ISSUE_TEMPLATE.md resources
CodingStyle.cc Jenkinsfile snap
CodingStyle.h libs src
CodingStyle.qml localization test
CONTRIBUTING.md QGCCommon.pri tools
COPYING.md QGCExternalLibs.pri UnitTest.qrc
Custom-Info.plist QGCInstaller.pri Vagrantfile
debian qgcresources.qrc WindowsQGC.ico
deploy QGCSetup.pri
doc QGroundControl.AppImage
root@rootwire:~/qgroundcontrol#

(DonLakeFlyer) #2

Are you trying to build QGC yourself? If so why? Why not just use a pre-built version?

(Brier K. Fox) #3

Well, since I seem to make everything harder than hell on myself, it looked like the only way to make it happen. I mean, I consider myself somewhat capable, but I’ve looked at several pages/posts/sites/threads and the ones I came across that I tried all would hit the dirt one way or another on my way through them.
I am always up for some fingers to point me in the right direction. I’m just hoping it’s not one of those “Oh… Look at that… I’m right back here again” moments that I keep being led to.

Thank you for your response though, it gets me a little closer to being no where closer than I am now… lol

~TheBrierFox

(DonLakeFlyer) #4

So I assume you are trying to build QGC yourself then. Not sure how you are trying to do that? Are you following the README? You build QGC using Qt Creator. Not sure what you are doing with qgroundcontrol.install? In fact I’ve never even noticed the debian directory before. Everything in there is unused.

(OldGazer) #5

Trust me, I feel your pain.

I know zip point nothing abut Ubuntu, but I’ve seen a couple of applications that only run on Linux so I figured I’d give the dark side a try. So far I’m 1 and 1.

I have Ubuntu and QGC running on my desktop, but for the life of me I can’t get QGC to run on my laptop.

What really has me baffled is the Desktop is running Windows 10 and Ubuntu in a dual boot configuration and the lap top is running a clean Ubuntu install on a clean hard drive.

(DonLakeFlyer) #6

What is going wrong with QGC on your Windows laptop? Most problems there are associated with Intel OpenGL graphics drivers which are crap. There are two additional QGC start links on Windows you can try to work around that.

(Shawn) #7

I used to use the .deb but the appimage files have been great - when there’s a version update just copy the new appimage right over the top of the old one, check for executable permission and you’re done!

1 Like
(OldGazer) #8

QGC runs on Windows just fine. I know about the Laptop Intel graphics issue.

The problem I am having is with a clean install of Ubuntu.

I took the original hard drive out of the laptop.
I put in a clean hard drive.
I put a Ubuntu installation DVD into the DVD drive.

I powered up and held F12 to get the Boot menu.
I selected the DVD.
Installed Ubuntu.

Downloaded the QGC AppImage and let Ubuntu do its thing…

Opened terminal and ran this: sudo apt-get install speech-dispatcher libudev-dev libsdl2-dev

QGC will not run.
I wiped the drive and tried again. No joy.

On the desktop I installed Ubuntu as a dual boot with Win10. All I had to do was download the AppImage. With my history with Windows dual boot I honestly expected this to fail but it works like a charm.

What gripes me is everyone says Linux it the bomb, but what they don’t tell you is if you make one false move “the bomb” will blow up in your face.

So my question is, why won’t QGC run on a totally clean installation of Ubuntu when it will run fine on a dual boot config? And no, I’m not about to setup a dual boot on my laptop…

EDIT:

And just so you know, APM Planner installs and runs just fine on Ubuntu…

(Shawn) #9

After downloading the appimage, open a terminal and change into the directory where you downloaded the appimage file, or where you copied it to:
for example:
cd Downloads
The prompt will change to “user@computer:~/Downloads$”

If you copied it to your Home directory, then you dont need to “cd” anywhere, the terminal will open in your home directory and the prompt will show “user@computer:~” (the tilda is like a shortcut for your home directory)
Then type or copy/paste:
chmod +x ./QGroundControl.AppImage
./QGroundControl.AppImage (or double click from in the Files GUI)

That should just work.
Let me know when it’s working and I’ll help set up a icon to start it from a “launcher” in the menus.

(DonLakeFlyer) #10

You don’t to do any sudo apt-get stuff with the AppImage. You just need to do what Shawn says.

(Oldgazer) #11

I finally have it working. I wiped the drive again and started from scratch, but this time I used a a bootable thumb drive and its working. Apparently the DVD has some file corruption. Odd that Ubuntu didn’t catch this during the original install.

I used the AppImage method and Qgc fires right up.

The next issue I had was with the USB serial port. Come to find out I needed to be added to a sub-group of dialout. Who knew?

Having a short cut would be great!!!

(DonLakeFlyer) #12

QGC should tell you what you need to change when it starts up if it finds a bad configuration.

(Khancyr) #13

Hello,

Use :

sudo usermod -a -G dialout $USER
(DonLakeFlyer) #14

Maybe a way to copy those commands from the popup QGC shows to the clipboard would be useful. I’ll make a note of that and change at some point.

(OldGazer) #15

I seem to recall doing that exact thing. Regular old ‘Copy and Paste’ works…

(Oldgazer) #16

Shawn:

I have qGC running now. I can run either the AppImage, or the Archive.

I think the root of my problem was I installed Ubuntu from a DVD and the data must have been corrupted.

I wiped the drive and installed Ubuntu from a thumb drive.

i got the AppImage running first, so I gave the archived build a shot. It runs but only from Terminal.

(James L Parmenter) #17

I followed your reply to OldGazer, " cd Downloads
The prompt will change to “user@computer:~/Downloads$”

If you copied it to your Home directory, then you dont need to “cd” anywhere, the terminal will open in your home directory and the prompt will show “user@computer:~” (the tilda is like a shortcut for your home directory)
Then type or copy/paste:
chmod +x ./QGroundControl.AppImage
./QGroundControl.AppImage (or double click from in the Files GUI)

That should just work."
Yesterday when I tried to change Directory’s, cd would not work, no such command or file found. Today, it worked fine…? Ubuntu-Mate 18.04 LTS, and QGC worked fine…! I have a dual-boot laptop w/Windows 7 & Ubuntu-Mate, QGC installed fine on Windows 7, and now it works on Ubuntu-Mate. Can you help me set up an Icon to start it from a “launcher” in the Menus…?
James…