INS_HNTCH_MODE Parameter is not showing in the mission planner

Hello everyone!!

I am planning to configure RPM sensor based Dynamic notch filttering to my copter. But the mission planner is not showing the params to activate.
Please let me know what to do to get these params in mission planner.

  1. INS_HNTCH_MODE = 0. Dynamic notch frequency control disabled. The center frequency is fixed and is static. Often used in Traditional Helicopters with external governors for rotor speed, either incorporated in the ESC or separate for ICE motors.
  2. INS_HNTCH_MODE = 1. (Default) Throttle position based, where the frequency at mid-throttle is determined by analysis of logs, and then variation of throttle position above this is used to track the increase in noise frequency.
  3. INS_HNTCH_MODE = 2. RPM sensor based, where an external RPM sensor is used to determine the motor frequency and hence primary vibration source’s frequency for the notch. Often used in Traditional Helicopters using the ArduPilot Head Speed Governor feature.
  4. INS_HNTCH_MODE = 3. ESC Telemetry based, where the ESC provides motor RPM information which is used to set the center frequency.
  5. INS_HNTCH_MODE = 4. In-Flight FFT, where a running FFT is done in flight to determine the primary noise frequency and adjust the notch’s center frequency to match. This probably the best mode if the autopilot is capable of running this feature. Currently, this is restricted to 2MB flash memory autopilots.


Download the beta of mission planner

Thanks for the reply Andy.

Can I do throttle based dynamic notch filter configuration with the latest mission planner 1.3.74?
Because the default is Throttle based dynamic notch filter config.


Should be able to. The parameters should be there regardless of which version of MP you are using (look in full parameter list), if they are not then that indicates a firmware problem rather than a MP problem

I have installed 4.0.7 firmware.
I have downloaded the logfile. It’s not showing any values in the graph.

What values are you looking for?

I am not getting this noise value.

All you need is FFT GYR0, it’s there.

Above picture is not mine.
I got this from ardupilot website. Just letting you know that I am not getting this value from the log which I got.

All you need for that is to set INS_LOG_BAT_MASK to 1

My problem is
My mission planner is not showing the INS_HNTCH_MODE parameters where I can change the value that I want to configure.

I made it as 1 only. And I flew drone more than 1 minute.
I can able to change INS_LOG_BAT_MASK parameter.

It won’s show that parameter until you enable INS_HNTCH_ENABLE

Post a link to that .bin flight log file.

And update Mission Planner to latest Beta anyway. Button on the bottom of the help screen.

1 Like

Facing one more problem.
In loiter mode
When drone is moving it’s maintaining the constant altitude. But when I stop the drone from moving the altitude is going down and again it’s coming back and holding the position.
What to do make the Drone not go down and holding position?
Please let me know

Please find the link below for a Log file

As I mentioned to see the INS_HNTCH_MODE parameter you have to enable INS_HNTCH_ENABLE and refresh parameters. You have this:

To enable Batch Logging for FFT you have to enable (set to 1) INS_LOG_BAT_MASK. You have:

1 Like

Thanks Dave. I will do that.

Kindly look into this loiter issue

Worry about loiter after you have configured everything. It looks like you have set some Initial Tuning parameters but others are at default. Did you use the Mission Planner Alt>A plug-in? Again update to MP latest Beta before doing so if you are on Stable still. The plug-in has changed.

1 Like

I did plug-in. I am using latest version of MP not a beta version.