Input inversion after take off

Dear all,

Today, I met similar result.

I use Cube Orange with Copter 4.0.4 in tarrot Quad copter.
In 1st flight, I test the response of quad copter.
This figure shows Input (RCIN1, RCIN2) and output (DesRoll,Roll,DesPitch,Pitch) signal.
It shows fine result.
RCIN1 and DesRoll are in same direction, also RCIN2 and DesPitch are in same direction.

Then, I add other equipments to the quad copter and tested it.
Followings shows results.

From 09:21:30, I used RCIN2 but DesPitch and Pitch moved in opposite direction, also DesRoll and Roll followed to them.
I awared that the quad copter responsed opposit direction in pitch, so I tried roll axis.

From 09:21:35, I used RCIN1, DesRoll and Roll rotated in opposit direction. Also DesPitch and Pitch follows RCIN1. I tried to move the quad copter by inverse RCIN1 input, and it successed to move it and safety landing.

During the operation, I felt that only each input was reversed.
But from those data, you can see that the roll and pitch are affected with one input (RCIN1 or RCIN2).
Also, it corresponds to one input signal before landing.

What’s going on?

You have super_simple mode enabled for the first five flight modes…


Dear Eosbandi-san,

I checked the log.
Oh, it’s set.
I don’t remember setting it, but it may have been set by my student.
I will check it by Flight mode setting inMission Planner, later.

Even if it’s due to super simple, there are things I don’t understand.

The first is that the operation was changed to the opposite direction (180 degree yaw rotation) even after the first armming and takeoff.

The second is that the operation was changed to the opposite direction during the flight.

Is this due to GPS reception or compass error?

Thank you.

Nicely found @Eosbandi!