Initial setup and bench testing, but having throttle issues

hello, I just finished the APM 2.5 build, and have been struggling during this part of the testing phase… I dare not let it loose yet as I dont trust anything, especially the RTL features…

anyways, I have some logs, and will try to upload them, (but Im not the best at this yet, so please forgive).

the problem I am having now, is the throttle up… it is spuratic. kinda like running watered gas in a fuel engine… it just sputters and cuts out… until it gets to about 50% throttle(?) then it seems more constant/consistent… the throttle jumps at initial acceleration, from 0-10% is almost instant, and the same in reverse… when landing/powering down, the motor speed will cut out from 10-20% down to idle/zero…

I have other issues, but lets deal with this one first, PLEASE…

frame: dji (clone) f450
controller/autopilot: APM2.5
esc:FLYCOLOR 30A (not sure if it is simonk)
motors:2826 - 1200kV MTM
propellers:8045 (and 1050 that I havent tried yet)
motor to motor distance: – inches 450mm
battery: 4s 2650 350-70
total weight: – lbs ???
flying time: ???
radio: turnigy 9x pro with FRSKY DJT TX & 8XR receiver
Misc (hacks/mods):

Hi bergovoy,

This sounds like an ESC calibration issue.

In other words the ESC’s have not been calibrated properly, and have no or incorrect information about the MAX and MIN value’s for the Throttle Channel.

Calibration on PIXHAWK is pretty strait forward.

Make sure you remove your props first !
Switch on transmitter, and put Throttle full up (Max Value)
Switch on PIXHAWK, and receiver, and power from a LIPO, as your Motors will need to get the power.
After switching on PIXHAWK goes into a specific mode (Blinking Blue/Red light)

Now remove power from PIXHAWK, and Switch on again…
Don’t change the Transmitter throttle settings…

After the PIXHAWK boot up process has been completed, press the Pre-Arm switch on the PIXHAWK.
Still no change on the Transmitter side…

If everything is fine and the ESC are loaded with SimonK software, you will hear a number of Beeps coming from each of the ESC’s…

This is the signal that each ESC registered the upper value of your Throttle setting.

Now move the Throttle on the transmitter, to the lowest value (down)

You will hear again a number of beeps, indicating the ESC registered the Lower values of your Throttle setting.

If you now slowly move up the Throttle each of the motors should start to spin slowly.

Moving up the throttle brings the motors to full speed. (Max Speed is now matching you max throttle value)

Remember that it is essential that you have done the Radio Calibration in Missionplanner BEFORE you try calibrating your ESC’s…

There are excellent descriptions here as well…, … esc-motor/

Hope this helps…


Thanks for the reply. I have the megapilot2.5 board.

I am very hard of hearing and can’t hear the beeps. I did do the calibration on the 2.5 several times. (after calibrating the radio in m.p. )

I will do it again tomorrow just to be sure.